Skip to Content
author's profile photo Former Member
Former Member

Cannot access sapdb backend from Content Server?

I am unable to access my sapdb from my Content Server via CSADMIN or with the /ContentServer.dll?serverInfo page.

I run a Content Server on Unix - version 640, build 16. Here's what I've verified thus far:

- SAPDB is up and running.

- x_server process is running

- apache is running (httpd processes)

- Standalone gateway on same server is running.

In the apache error logs I find the following message:

ErrorDescription: Cannot start Document request, reason: SQLConnect

failed, [MySQL MaxDB][LIBSQLOD SO][MaxDB] Invalid authorization specification;-4008 POS

(1) Unknown user name/password combination, Error

Code: -4008\r\nX-ServerId: server="nwkwcs";serverPort="1090"\r\nX-

ServerType: SAP HTTP Content Server\r\n

I had not changed my SAPR3 user or password in the database, so I am confused why this started happening all of a sudden?

In an attempt to fix, I reset SAPR3 to custom password and ran report

RSCMSPWS to store the new password in the cs.conf file. However, the

same error is still a result.

So, I deleted and recreated SAPR3 based upon SUPERDBA profile with default "SAP" password.

Then, I commented out DBNAME and PASSWORD in cs.conf file. So, it should be using the default SAPR3/SAP login to the database.

However, this did not help either.

I looked at note 706664, however I cannot even get the repositories to a defined status. I cannot connect via CSADMIN?

Here's an excerpt from the http://server:port/ContentServer/ContentServer.dll?serverInfo page for

further analysis:

serverType="SAP HTTP Content Server";serverVendorId="SAPAG";

serverVersion="640"; serverPatch="0";serverBuild="16";

pVersion="0046";serverStatus="running";serverDate="2008-07-

10";serverTime="13:58:28";startUpDate="2008-07-10";

startUpTime="13:58:20";lastAccessDate="2008-07-

10";lastAccessTime="13:58:20";

contRep="Z_EKM_IWBHELP";contRepStatus="offline";contRepStatusDescription="SQLConnect failed, [MySQL MaxDB][LIBSQLOD SO]

[MaxDB] Invalidauthorization specification;-4008 POS(1) Unknown user name/passwordcombination, Error Code: -

4008";storageVersion="17";storage="SAPDB";buildLevel="1";contentStorageName="SDB";contentStorageHost="localhost"; security="1";contRepDescription="Content Repository for IWBHELP";

I am unsure why the Content Server will not connect to the database?

Points to all helpful answers!

Thanks,

Jeff

Add a comment
10|10000 characters needed characters exceeded

Related questions

1 Answer

  • author's profile photo Former Member
    Former Member
    Posted on Nov 11, 2009 at 09:25 AM

    Hi,

    How did you resolve this problem ?

    Thanks,

    Hemant

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.