Skip to Content
1
Former Member
Jul 10, 2008 at 04:46 PM

SMD Agent Setup failed sp15

107 Views

Hi all,

I am installing SMD Agent on my Dev server, using SMDAGENT13_0-20001671.SAR

All is fine untill the 'Lookup HTTP Connection via Message Server' Parameter

I get the error message

Make sure that the LMSERVICE.SCA is deployed and that the SMD server is not running under maintenance mode. Choose "Cancel" to modify managing configuration or "OK" to continue. If you choose to continue, the SMD Agent Setup step will fail during installation.

I have deployed the SCA to the DEV server

LMSERVICE14P_5-20001429.SCA

And the solution manager is not in maintenance mode

if i continue the installation, it will finish but leave the following error in the log file

- STEP 7: checking P4 Connection and SMD Agent Registration

External Command Executed:

C:\j2sdk1.4.2_14-x64\bin\java -DP4ClassLoad=P4Connection -Dsap.p4.remote_classloading=false -cp "lib\sapxmltoolkit.jar;lib\smdagent.jar;lib\tc_sec_secstorefs.jar;lib\iaik_jce_export.jar;lib\logging.jar;lib\smdserver.jar;lib\exception.jar;lib\sapj2eeclient.jar;lib\launcher\smdagentlauncher.jar" com.sap.smd.setup.Setup /p4connection

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

P4 Connection succeeded but SMD Agent Registration failed

Root exception is: com.sap.engine.services.jndi.persistent.exceptions.NameNotFoundException: Object not found in lookup of smdserver.

-


ERROR!!! SMD Agent Setup failed - Please retry

-


The Solution manager server doesn not show the agent, but the server existis in SMSY.

I must be missing something, has anyone had the same problem or has a fix?

Thanks

Edited by: Mike Gordon on Jul 10, 2008 4:48 PM