Skip to Content
0

HANA Express - Data Services Connectivity

Oct 27, 2016 at 05:53 AM

159

avatar image

Hello,

I am running HANA Express in a VMware environment. I'm trying to connect to HANA Express from another VM on the same system.

I've set up a separate network bridge for the two systems to talk to each other, and that solved my initial issue that the Data Services Job Server couldn't find the HANA system at all, even thought I could view metadata within a Data Services Datastore created to connect to HANA, and could import tables into Designer, and view data within a HANA table within Designer. Designer is on the same system as the DS Job Server.

By simplifying my HANA VM's networking connections I was able to get past my initial error, now, however, I can initiate a connection from my DS VM to the HANA VM in a job, but not vice-versa. I get this error:

54247032CON-12030210/25/2016 2:31:04 PMODBC call <SQLDriverConnect> for data source <HANAExpress_IP> failed: <[SAP AG][LIBODBCHDB DLL][HDBODBC] Communication link 54247032CON-12030210/25/2016 2:31:04 PMfailure;-10709 Connection failed (RTE:[89006] System call 'connect' failed, rc=10060:A connection attempt failed because the 54247032CON-12030210/25/2016 2:31:04 PMconnected party did not properly respond after a period of time, or established connection failed because connected host has 54247032CON-12030210/25/2016 2:31:04 PMfailed to respond)>. Notify Customer Support.

I believe I need to modify the hosts file on my HANA Express VM to include the IP address and server name of my Data Services VM, but since I don't have the root password I can't do that.

Has anyone seen this, or can anyone help?

Thanks,

Tony

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

avatar image
Former Member
Nov 03, 2016 at 07:36 PM
0

You can change the /etc/hosts file using sudo

sudo vi /etc/hosts

Share
10 |10000 characters needed characters left characters exceeded
Tony Maas Nov 30, 2016 at 06:23 PM
0

Thanks, I did eventually get there but making this change didn't help me. Even with both hosts able to ping each other and connect from my Data Services VM to my HANA Express VM using Eclipse and HANA Studio, I'm not able to run a Data Services job. Same errors as above.

Support doesn't have anyone that can help me with this, by their own admission.

Any other ideas I can try on this? I can create and save a Datastore connection in Designer to the HANA Express database, import tables, and basically doing anything in Designer I want to do. But when I run the job it fails.

Regards,

Tony

Share
10 |10000 characters needed characters left characters exceeded