Skip to Content

Lumira Universe Query Panel Extension - date format - valid date required (prompts)

Hi Lumira and BO Query Experts,

I have an issue with the Lumira Desktop 1.31.8 using the Universe Query Panel Extension. SAP BO 4.2 SP 04 Patch 04. The cause of the issue is the forced @Prompt function in the universe for specific measures.

@Prompt('Enter execution date','D',,Mono,Free,Persistent)
Data Type :DateTime

Then the value of this prompt is entered into the measure's WHERE clause:

CALENDAR_TRANS.FULL_DATE=nvl(@Select(Directory\pExecution Date), trunc(sysdate))".

The following prompt works fine with WebI because it uses the WebI Locale formating and offers the calendar date picker functionality.

However, the Universe Query Panel Extension prompts users without the calendar date picker and uses the date format that is unknown.

Image 1:

I have found the SAPnote:

2389359 - Lumira Query Panel Extension does not have a date picker for date prompts

Followed the note and the mentioned kbase 2220451 to enable Lumira Utility logging.

Collected the logs and entered the dates I have found in the log and Lumira still warns that "a valid date is required". I have no idea what to do to be able to run the query in this case.

Step by Step

  • I have enabled the Lumira Logging
  • Launched Lumira Dekstop
  • Create New Document using the Universe Query Panel Extension
  • Create a simple query with @promp measures
  • Made a refresh result set and it worked fine (see the result set below)
  • Please note this allows to use the calendar date picker and seems to work fine.
  • Pressed finish and in the next step (window) got stuck with date format as shown on Image 1 above.
  • Gathered the generated Lumira log files

In the log files I have found several date formats. None of those worked in the final step as shown in the first image.

WHERE  ( CALENDAR_TRANS.FULL_DATE=nvl(( ('20-02-2018 00:00:00') ), trunc(sysdate))  )  AND    (  CALENDAR_CAL.YEAR  =  2017  AND  CALENDAR_CAL.MONTH_NO  =  10  AND  CALENDAR_CAL.DAY  =  11  )
="(parameterId: pmEnter execution date, dpId: 68bf8039-, selectionType: MultiValue, dataType: Date, valueObjectType: Flat, definitive: false, value: 
((captionField: Feb 20, 2018, keyField: null)))", 
QuerySpec: ="<?xml version="1.0" encoding="UTF-8"?>
|E7368D2545AB450AAA|Information| |==| | |TraceLog| 8348|  43|qtp948424584-43 | |0|27|0|1|-|-|-|-|-|-||||||||||com.businessobjects.semanticlayer.qt.internal.ParameterService||Parameter question : Enter execution date|E7368D2545AB450AAA|Information| |==| | |TraceLog| 8348|  43|qtp948424584-43 | |0|27|0|1|-|-|-|-|-|-||||||||||com.businessobjects.semanticlayer.qt.internal.ParameterService||Values : ('20-02-2018 00:00:00')

I have tried a number of date formats but still cannot enter the valid date format into the @prompt functions.

I have used the date format used in:

Lumira Logs - 20-02-2018 00:00:00

Lumira Logs - Feb 20, 2018

DB - 20/02/2018

Query Panel Refresh Details - 2018-02-20 00:00:00.0

Query Panel Refresh Details (export) - 2018-02-20 00:00:00 000

Show values from IDT universe - 20-Feb-2018 00:00:00

Export using WebI from table Calendar_trans 20.02.2018 00:00:00

WebI Prompt 20/02/2018 12:00:00 AM

And many more but I still did not manage to pass this date prompt.

Thank you in advance very much for your help.

Vytautas Thienel

lumira.png (58.6 kB)
query-panel.png (49.7 kB)
sap-lumira.png (13.2 kB)
Add comment
10|10000 characters needed characters exceeded

  • Hello - a quick suggestion is to try this with Lumira 1.31.10 just released this week and see if you experience the same.

  • Hi, thanks for the quick reply. I have only tried to install the 1.31.10 Lumira Desktop (win client) and have experienced the same issue. I am not sure how much it depends on Lumira, but it seems to be related with Lumira extension - Universe Query Panel.

    I have not tried to update Lumira Server, since it takes some time to do that.

  • Tammy Powlas Vytautas Thienel

    I would open a SAP Support ticket and reference this thread; you have documented this very well

  • Get RSS Feed

0 Answers