Skip to Content

Crystal reports for Visual studio 2010 CR Viewers Print Dialog Crashes

I have created a vs2010 win app that uses Crystal-reports 13.0 sp22 The app is deployed on a work-group of 4 computers There is a printer connected to the network visible from all PCs All PCs can print to the printer except one This one can print from all programs eg notepad, PDF but not from my app The user clicks on the viewers button to print, the print dialog shows up but when print button is clicked or layout tab is clicked the app crashes.

Checking the event viewer I get two application errors:
Number 1:

Application: InsuranceAgent.exe Framework Version: v4.0.30319 Description: The process was terminated due to an unhandled exception. Exception Info: System.ArgumentException at System.Globalization.RegionInfo..ctor(Int32) at CrystalDecisions.Windows.Forms.CrystalReportPrintDialogCustomPanel.GetPaperSizeString(Double, Double) at CrystalDecisions.Windows.Forms.CrystalReportPrintDialogCustomPanel.UpdateChoices() at CrystalDecisions.Windows.Forms.CrystalReportPrintDialog.UpdateSelectedPrinterOnPanel() at CrystalDecisions.Windows.Forms.CrystalReportPrintDialog.CrystalReportPrintPropertySheetDlgProc(IntPtr, CrystalDecisions.Windows.Forms.Internal.WindowsMessages, IntPtr, IntPtr)


Number 2:

Faulting application name: InsuranceAgent.exe, version: 2.0.6622.2791, time stamp: 0x5a876a70 Faulting module name: KERNELBASE.dll, version: 10.0.16299.248, time stamp: 0x4414ec23 Exception code: 0xe0434352 Fault offset: 0x0000000000014008 Faulting process ID: 0x27fc Faulting application start time: 0x01d3a782bfac72fc Faulting application path: C:\Program Files (x86)\PNSoftware\Insurance Agent\InsuranceAgent.exe Faulting module path: C:\WINDOWS\System32\KERNELBASE.dll Report ID: 70ffc331-1923-4f03-b06e-e07935328527 Faulting package full name: Faulting package-relative application ID:

This Happens only in this PC all others are OK and all the same win10 OS

Any help will be deeply appreciated

Thank you all in advance

What I have tried:

To use different settings in page setup like:
checking No Printer (optimize for screen display) with no luck
Tried different regional settings as well on that PC ...

I use the CRRuntime_64bit_13_0_22

1.jpg (147.5 kB)
Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

5 Answers

  • Best Answer
    Feb 22 at 04:42 PM

    Hi

    After all the problem was solved
    I cannot explain why but only how !!!!!

    I changed the regional settings ( the format tab ) to English United States
    Any other setting does not work eg. English United Kingdom
    The funny thing is that on the network all other computers they have regional settings Greek and the application is working fine

    Would be great to have an explanation but it is working ...

    Don thank you so much for helping

    All the best

    Nikos

    Add comment
    10|10000 characters needed characters exceeded

  • Feb 21 at 09:10 PM

    Hi Don
    Thank you for that
    I will check this out tomorrow as I don't have access to that PC right now
    I can only have a look by Team Viewer as it is far away
    The app is installed in a few work-groups only this case is so weard
    I will let you know what happened
    Cheers

    Add comment
    10|10000 characters needed characters exceeded

  • Feb 22 at 04:33 PM

    Hi Don
    There is no Run As Administrator for the run time in win 10

    I did some changes to registry
    HKEY_CLASSES_ROOT\Msi.Package\shell ---> added a new key named it "runas"
    in the new key I changed the default value to "Install as &administrator"
    I added a sub-key to the runas key named it “command” setting the default value to msiexec /i “%1”

    This gave me the option Install as administrator
    I managed to install my app as administrator by right click on the setup file "run as administrator"
    For the msi run time file "CRRuntime_64bit_13_0_22" by right click and click "Install as administrator" I got this after the UAC

    The logged in user is an administrator account
    By just double click or right click and install to the CRRuntime_64bit_13_0_22 the installation continues

    No luck :(
    It is driving me crazy ... in all PCs no problem except this one and in this one only the CrystalReports viewers print dialog
    I have added a test print button to my app to print a dummy page after launching a print dialog to select a printer and it works fine

    Add comment
    10|10000 characters needed characters exceeded

  • Feb 22 at 04:36 PM

    Huh... Yes there is:


    It looks to me like that user Profile is either modified or limited or corrupted.

    Try logging into that PC as a Local PC admin and install it.

    Don

    Add comment
    10|10000 characters needed characters exceeded

  • Feb 21 at 07:31 PM

    Hi Nikos,

    Likely an issue with the printer driver. Try removing it and reinstall it.

    If that doesn't fix it then sue DebugDiag on that PC and see what the Dump file indicates.

    Make sure the Printer, your app and CR runtime is installed by right clicking on the setup.exe's and selecting Run As Administrator.

    Could be a permission issue.

    Don

    Add comment
    10|10000 characters needed characters exceeded