Skip to Content

"Enter Plant" error using CALL TRANSACTION with BDC data for transaction ME11.

Hi,

I'm really at the end of my teather with this issue.

I'm getting an'Enter plant' message 06 381 when using BDC via a CALL TRANSACTION against transaction ME11, used to create a new PIR. We never enter a Plant, ONLY providing Vendor, material and purchase org. So the message saying 'Enter Plant' is a bit of a mystery. If I manually enter ME11 and put the same data as used in my recording I can successfully create a PIR as well.

Initially I was using the MODE (P) and UPDATE (S) options for CALL TRANSACTION, but I found that if I changed the MODE to 'A' and actually stepped through the recording on screen then it always worked just fine, but when running in background then did not, even though it's the same recording.

My next step was to use the OPTIONS parameter ( Type ctu_params) to replace the MODE and UPDATE options. Setting 'NOBINPT' to 'X' should force the background process to behave as though running in foreground I believe, but I'm still getting the 'Enter plant' message, regardless of the OPTIONS paramter.

  gv_options-DISMODE  = 'P'.
  gv_options-UPDMODE  = 'S'.
  gv_options-CATTMODE = ' '.
  gv_options-DEFSIZE  = ' '.
  gv_options-RACOMMIT = ' '.
  gv_options-NOBINPT  = 'X'.
  gv_options-NOBIEND  = ' '.

I have also tried setting the 'DEFSIZE' to 'X' and also changed the DISMODE to 'E', but nothing makes a difference. As well as that I have also set NOBINPT to SPACE as well, as help on this option is a little confusing. Still no joy though.

My CALL line of code looks like this:

CALL TRANSACTION 'ME11'
     USING lt_bdcdata 
     OPTIONS FROM gv_options 
     MESSAGES INTO lt_messtab.

Any suggestions would be more than welcome.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • Best Answer
    Feb 20 at 12:17 PM

    I think it simply is based on the values you have in lt_bdcdata

    What value do you submit in the plant field?

    The screen is hardcoded and it is not even easy to make that field mandatory as you can read in OSS note 1860711 - How to make plant field mandatory in transaction ME11

    Add comment
    10|10000 characters needed characters exceeded

  • Feb 22 at 09:02 PM

    As you have tested all basic possibilities, you should better run a SAT trace for the batch input mode and another one for the real mode, and compare automatically the 2 traces with the compare button. When you know why there is a difference, then you can make a decision.

    Add comment
    10|10000 characters needed characters exceeded

    • Thanks Sandra, I have resolved the issue now, but I keep that in mind for the next similar related problem.

      Much appreciated.

  • Sep 25 at 05:50 PM

    This was a strange one indeed. It turns out that the user being used to run the jobs did not have an entry in the User profile, whereby there was no Building code entered.

    Add comment
    10|10000 characters needed characters exceeded