Skip to Content

[Solved] SAC Data refresh button generates error.

Feb 21 at 11:06 AM


avatar image

Data from live connection (SHC) is not updating SAP Analytics Cloud table view when the data refresh button clicked. To force data update I have to change a filter selection e.g. change a date

If I edit and save the story the refresh button works. When re-opening the story the refresh fails again,

Error message from chrome browser console

app.chunk.12.slice_of_main-chunk.a8454818649cd8dbfb80.js:10 Uncaught (in promise) Error: Entity service is not initialized
    at Object.E.processDimensions (app.chunk.12.slice_of_main-chunk.a8454818649cd8dbfb80.js:10)
    at Object.n [as processQueryDefinition] (app.chunk.12.slice_of_main-chunk.a8454818649cd8dbfb80.js:27)
    at constructor.processQueryDefinition (app.chunk.8.slice_of_main-chunk.1f0a167524e7ceb64eb9.js:12)
    at constructor.updateGridLayouter (app.chunk.8.slice_of_main-chunk.1f0a167524e7ceb64eb9.js:6)
    at f (app.chunk.1.slice_of_main-chunk.07b14b40b7ce12b7dd6a.js:8)
    at <anonymous>

Any ideas ??



10 |10000 characters needed characters left characters exceeded

Steve - I would open a SAP Support incident under component LOD-ANA-BI

Only close item I could find is this - you can check the second situation but I am not sure it relates; it has a similar error


Thanks for that Tammy I will take a look.

I have a support call open but no resolution yet - looking for hep from the wider community !

* Please Login or Register to Answer, Follow or Comment.

2 Answers

Best Answer
Adam Mehesz
Feb 21 at 04:26 PM

Hi Steve,

Could you please check the following article:

It describes the same issue that you experience and it is planned to be fixed in Wave 2018.03 which is planned to be deployed in this week.

Best regards,

Show 1 Share
10 |10000 characters needed characters left characters exceeded

Thanks for the answer Adam, the refresh for these views was working previously, and is critical for our application. Look forward to trying the new version asap



Steve Green Feb 26 at 09:00 AM

Just tried Version 2018.3.0.

Refresh button is working


Steve Green

10 |10000 characters needed characters left characters exceeded