Skip to Content
0

some filds imported with empty value from SAP infoset query

Feb 20 at 07:32 PM

85

avatar image
Former Member

Dear experts

I have infoset query filled from external program and query returns all 39 filed correctly for all columns data when it running on sap ERP side.

But when consuming this query from SAP Analytics cloud, there are about 6 columns doesn't have any data value ,they are empty , although they have data on sap query.

please advice

10 |10000 characters needed characters left characters exceeded

Maybe you could share more fields/screen shot of the query?

0

Hi Hady,

Were you able to figure this issue out?

0
* Please Login or Register to Answer, Follow or Comment.

2 Answers

avatar image
Former Member Feb 21 at 08:20 AM
0

This is some filed of structure filled by program then to the query

and all data displayed on query and on sap analytics cloud

but those fields transfer with empty data


11.png (45.1 kB)
22.png (60.6 kB)
Share
10 |10000 characters needed characters left characters exceeded
Julian Jimenez
Feb 21 at 07:45 PM
0

Hi Hady,

Are you using the same user account in SAP Gui and SAC?

I presume that when you preview this data using that account, you can see values in those columns. If you have another client tool that an connect to the Infosets: Crystal or others, it would be useful to see if you get the same behaviour.

Ultimately, you can find information on Tomcat logs (Cloud Agent) if there are errors.

Thanks,

Julian

Show 4 Share
10 |10000 characters needed characters left characters exceeded
Former Member

HI Julian

Sure, i am using the same user on SAP GUI and SAC.

I also tried to consume this infoset query using SAP LUMIRA and the same problem exist.

0

Hi Hady,

If you have the same problem in Lumira, it means that your user doesn't have rights. You need to check with your ERP administrator to be sure that the user has the required authorizations to read that data.

Regards,

Julian

0
Former Member

Hi Julian.

I use the same user on sap GUI and connection to SAC.

Data which doent appear are come from ZTABLE and i already can view it on sap GUI.

0

Hi Hady,

I am not an expert in ERP. I believe you should trace your user when connecting from Lumira and verify the errors displayed. It may be related to missing authorization.

Regards,

Julian

0