Skip to Content
0

Connecting to HANA Express edition on GCP

Feb 21 at 05:30 AM

71

avatar image

Hello,

I have installed the HANA Express Edition on GCP, followed the instructions as per below tutorial.

https://www.sap.com/india/developer/tutorials/hxe-gcp-getting-started-launcher.html

Now when trying to connect to HANA Server from HANA Studio, it says 'the system cannot be reached the logon data could not be used'.

I made the external IP as a static one in GCP, and added the external ip in my host file as shown below. Now from HANA studio, iam trying to connect to hxehost , instance 90, multicontainer -> system database with SYSTEM user.

Host File is update with below entry

35.200.143.10 hxehost

I also checked the firewall rules and tcp:39015 is allowed in GCP.

Note - i have already searched the previous posts and followed the suggestions, but had no luck.

please help

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Lucia Subatin
Feb 21 at 01:15 PM
0

Hi, Naveen,

I would start by:

1- Do you get a reply if you ping the external IP from your computer?

2- Do you get a reply if you ping hxehost from your computer?

3- In the console in GCP, as hxeadm, what is the output of ./HDB info ?

4- Can you telnet hxehost 39015 and connect?

5- What version of HANA Studio do you have?

Pls bear in mind that when you set the IP to static, GCP changes it so if you did mapping before setting it to static that may be the problem.

Show 3 Share
10 |10000 characters needed characters left characters exceeded

Hi Lucia, Thank you for replying.

Actually i have been trying my luck from past few days in office and i did not work at all. Today when i saw your reply, i was actually at home and gave a quick try and it worked like a charm. So there could be some firewall which is blocking me in our office network? how do i check this and enable or disable something to make it work?

FYI - i have already tried all the option you suggested me above when i was in office and none of them worked.

Regards,

Naveen

0

Right, looks like there is something blocking you if ping does not get a reply. If number 1 fails, the rest of the steps will fail. If you work with IT to enable traffic, make sure you give them all the port and ranges in the firewalls in GCP as you could could some weird errors by partially enabling ports.

0
Former Member
Naveen Brungi

Usually Corporates or ISP only allow ports HTTPS - 443 and port 80 so i would suggest by issuing a telnet command prompt to GCE machine on port 39015 (tennat HXE DB) When you are connected to the office network if so

i would suggest you install socat linux utility on GCE (assumimnng it is suse enterprise linux 12.x version)

once you have socat installed as root issue a comand like example :

socat TCP-LISTEN:80,TCP:localhost:39015 in a terminal window and keep it open

then from eclipse sap hana studio you can then use port 80 in System view to connect to HXE tenant db

or have a lok SSLH which does port multiplexing available as a free utility

thanks

rama anne

0