Skip to Content

Error when executing Iflow

Feb 20 at 03:01 AM


avatar image

Hi All,

I have created iflow to fetch exchange rates from the web service and use that in another integration process"Salesorder summary" for conversion. Exchange rates values, im writing to the Data store using write operation. Please refer the iflow screenshot for more information.

When i tried to execute the Iflow,integration process "Exchange Rates" is not creating Data store and the messages are getting failed with the below error.

Error Details:

Inbound processing in endpoint at /SIOA_SalesOrder_DS failed with message "Fault:org.apache.camel.CamelExchangeException:Sequential processing failed for number 1. Exchange[ID-vsa3679993-44639-1518877048481-25-6].Caused by: [org.apache.camel.RuntimeCamelException

No message found for id USD in store CurrencyRate for integration flow CPI_DataStore_Test]", caused by "MessageNotFoundException:No message found for id USD in store CurrencyRate for integration flow CPI_DataStore_Test"

Can someone help me to fix this issue?


Bhargava Krishna

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

Sriprasad Shivaram Bhat
Feb 20 at 08:57 AM

Hello Bhargav,

From the error it is clear that your Second Sequential multicast branch with GET is not able to find the message.

Please check below 3 things.

1) Whether Data Store entry created out of Exchange Rates Integration Process or not.Please add End Message step after Write step.

2) Try to trigger second integration process only after confirming Entry exist in the data store.

3) Check the Visibility option in Data store.

4) Try adding static entry id in WRITE step and use the same in GET step.


Sriprasad Shivaram Bhat

Show 2 Share
10 |10000 characters needed characters left characters exceeded

Hi Sriprasad,

Thanks for the response.

--> Data store is not getting created after deploying the iflow.

--> I have created another Iflow and configured only exchange rates integration process.. It is fetching the data and creating Data store.

--> If I execute exchange rates integration process along with the sales order integration process,(As shown in the above in the image) it is not creating Data store.

--> Visibility I have selected as Global and tried changing it to integration flow but still facing the issue.

--> I have already defined "${header.SourceCurrency}" as Entry ID in write step and "${xpath.//Order/Item/Currency}" in Get step.


Bhargava Krishna


Hello Bhargava,

This iFlow should work without having a process call as you have used timer. But, l feel using process call this might work properly. Try having a process call to call the exchange rate Local Integration process and check. Let us know what you get in this.


Nitin Deshpande

Somen Mohanty Feb 23 at 06:25 AM


By looking at your iflow, you are missing a end event in the main process after the write.

This might be the reason of error.

10 |10000 characters needed characters left characters exceeded