Skip to Content
author's profile photo Former Member
Former Member

BDCdata not uploading

In Function Module i am using BDC its appending data in

BDCDATA succefully but when i call Trasaction .. my screen is blank..

way..

here is my code..

data l_mode.

l_mode = 'N'.

CALL TRANSACTION 'XD01' USING bdcdata3

MODE l_mode

UPDATE 'S'

MESSAGES INTO messtab.

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

4 Answers

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Jul 05, 2008 at 01:49 PM

    Hi,

    Please make the Mode as 'A' while running the program in debugging mode and check if the values are coming properly to the XD01 screen. Correct the errors if you get any.

    Regards,

    Nadim

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Jul 05, 2008 at 01:50 PM

    Hi Jim,

    How u declared ur internal table bdcdata3?

    If u declared with header line then pass it like this.

    CALL TRANSACTION 'XD01' USING bdcdata3[]

    MODE l_mode

    UPDATE 'S'

    MESSAGES INTO messtab.

    Also put a break point at call transaction statement and change l_mode value from N to A and check whether values are getting populated or not.

    Thanks,

    Vinod.

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jul 05, 2008 at 02:14 PM

    yes i am Using Mode 'A' in Debuging.. and this is my Custmize

    bdc data.. i.e bdcdata3.. and its successfully appending all values includeing Fnam and Fval.

    any other clue.?

    Add a comment
    10|10000 characters needed characters exceeded

    • Hi Jim,

      Then there must be problem with populating BDC data. If the bdc data is not in same order as it is in recording it wont work. Compare your coding(Population of BDCDATA 3 table) with your recording. I don't think there is any other problem.

      Also paste ur code so that if it is identifiable then we may help u out.

      Thanks,

      Vinod.

  • author's profile photo Former Member
    Former Member
    Posted on Jul 05, 2008 at 02:22 PM

    hi....

    just check the screen number and also see if you are passing the values properly in the field .

    the name of the fields in which you are passing the values should not be in inverted colons.

    just check the screen numbers as well.

    and debug in 'A' mode to check if BDC is running properly or not.

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.