Skip to Content
avatar image
Former Member

capping dev_ms trace file size

hi - i'm wondering if anyone knows a way to help. we have been asked by SAP to run our msg server at an elevated trace level (trace level 3 - we set it from SMMS). this writes out a huge amt of data to the dev_ms trace file.

the default trace file (dev*) size, per the rdisp/TRACE_LOGGING param default is "on, 10m" (i.e. 10mb).

that applies to "all" the dev* trace files obviously.

w/ our elevated dev_ms trace set, it's overwrapping in ~3 min ...so between dev_ms.old and dev_ms, we never have more than ~10 min of logs kept at any one time.

the pt of us running at this elevated dev_ms trace level is so we can capture (save off) the trace file and send to SAP the next time our msg server crashes.

our SAP file system mountpoint /usr/sap/<SID> is limited in size...and by setting rdisp/TRACE_LOGGING value to a higher value it affects all the dev* files, not just the 1 file i really care about increasing the capped file size on (dev_ms).

**QUESTION*: does any one know a way i could keep dev_ms capped at a large value like 100mb yet keep all the other dev files at the normal 10mb default? thanks in advance

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • avatar image
    Former Member
    Jul 03, 2008 at 08:47 PM

    1. Increase rdisp/TRACE_LOGGING to 100MB.

    2. Set (SM51) > Select All Processes > Menu > Process > Trace > Active Components > Uncheck everything and set trace level to 1.

    3. Menu > Process > Trace > Dispatcher > Change Trace Level > Set to 2

    Wouldn't this essentially just increase dev_ms to 100MB while leaving other dev* trace files to not log anything?

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      welcome! good luck w/ finding the answer and please do post it if you do. and, have a wonderful 4th (assuming you are in US, I see a US flag in your profile).