Skip to Content
avatar image
Former Member

No batch process available. Process terminated

Hi all,

Our BW developers are recieving this message: ?Resource error. No batch process available. Process terminated

i see nothing suspicious on any log. Can you guys guide me in the right path..?

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

7 Answers

  • Best Answer
    avatar image
    Former Member
    Jul 03, 2008 at 03:45 PM

    Hello,

    Go to sm50 and see how many BTC type process are available. If any, that's the reason why.

    Diogo.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jul 03, 2008 at 09:23 PM

    Check SM50 for all the BGD process available if not convert some of the DIA process to BGD.

    Also check SM51 in case of many servers and then double click to check for processes availability.

    Hope it Helps

    Chetan

    @CP..

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jul 03, 2008 at 03:44 PM

    Hi,

    Not sure on the error. But I guess you can contact the BASIS. They should help you.

    Bye

    Dinesh

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jul 04, 2008 at 10:30 AM

    Hi,

    There is certian number of processes available to perform various tasks like extraction, loading etc. If you trigger a job for any operation and all the process are engaged in some other jobs you will get this error.

    Make sure you do not overload the system by triggering so many jobs at a time. SM50 is the transaction where you can monitor how many processes are used and how many are free.

    Regards,

    Yogesh.

    Add comment
    10|10000 characters needed characters exceeded

    • Basis are the only folks that can find this information. They know where to find this (probably SM21 and given them data, time and add * in User ID).

      >

      > thank you all for hte great responses. But as the problem appears during hte night, i can't be checking sm50 to see what is happening. is there a way i can grab a snapshot of sm50 during hte time this job that fails is supposed to occur?

      > thank you!

      Please provide this informaton on questions like this.

      1) How long have you been getting this problem.

      2) Did you move/schedule any new Process Chains recently. You should look into Load balancing before starting too many loads/P-CHains.

      3) How many App Servers do you have? I doubt if you have only one. You may have 3 or 4. Maybe one of the app server failed and the others may be working.

      Anyway, adding 2 more Batch Processes in atleast 1 or 2 app servers (even in PROD) is not a big deal. Tell BASIS to add them and they can take them off if not needed.

      THis is mostly BASIS work even thought you as a developer is responsible to give them proper instructions on how many parallel Background and Dialog processes you need at night.

      Good luck.

      Uday-Ram Chamarthy

      Edited by: Uday-Ram Chamarthy on Oct 8, 2008 7:45 AM

  • avatar image
    Former Member
    Oct 08, 2008 at 02:16 PM

    Hi Samer,

    Try following steps:

    RSA1 >Administration >Current Settings >Batch Manager >Settings for Parallel Processing >select " ODS Activation" >select your DSO just maintain it to 1 or 2, try tweaking these processes and make sure you have enough background processes.

    It is working for me now...

    Regards,

    Shalin Shah

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Mar 06, 2009 at 12:44 AM

    The CCMS for BW captures data on the number of background processes that exist and the maximum number used ina given time period ( I believe this is reported hourly ), e.g. it will tell you that between 4am and 5am you had 16 batch processes available and the maximum used during that period was 12. Alerts can be configured to monitor if you are getting close.

    As a quick alternative, if you look at SM37 and see where you have large numbers of jobs that ran in a short ime frame, that is proably your culprit. If you look at your process chains and see which ones run at the same point, you can also probably get an idea on where you have too many processes running at one time.

    Add comment
    10|10000 characters needed characters exceeded

  • May 15, 2009 at 04:07 PM

    you have increased the number of batch processes.

    Below you can check the recommended adjustments to the Data Store obj

    parameters in transaction RSODSO_SETTINGS.

    1) maximum package size (for activation)

    This you should reduce to 10000. Then the package processing would

    be less time consuming.

    2) maximum wait time for process (for activation)

    This is currently set to 300 and could be increased e.g. to 600

    3) button "change process parameters"

    here the activation is set to be run in backround (which is also

    adviced by SAP).

    If you want the processes to run in backround, you may have to

    increase the amount of batchjobs available in your system. Otherwise

    the activation can not run in parallel if there are no batchjobs

    available. This could also occur because there are other programs

    using batchjobs also.

    Please check these settings and reactivate the DSO.

    Also, there is some notes that can help you:

    1118205 - RSODSO_SETTINGS Maintain runtime parameter of DataStore obj.

    (In this notes is mentioned more instructions + 2 notes:

    25528 - Parameter rdisp/max_wprun_time

    192658 - Setting parameters for BW systems)

    0024092 - Distribution of background jobs on application

    regards,

    Colin Moloney

    Add comment
    10|10000 characters needed characters exceeded