Skip to Content
0
Former Member
Jun 30, 2008 at 11:10 AM

Negative cache - ClassLoader

10 Views

Hi,

I get this warning message when trying to access my webdynpro service :

com.company.ayantdoit.models.zayantdroitgetascmodel.Zayantdroit_S Found in negative cache -


Loader Info -


ClassLoader name: |com.company.tv1/essfrayantdroit3|

Parent loader name: |Frame ClassLoader|

References: common:service:http;service:servlet_jsp service:ejb common:service:iiop;service:naming;service:p4;service:ts service:jmsconnector library:jsse library:servlet common:library:IAIKSecurity;library:activation;library:mail;library:tcsecssl library:ejb20 library:j2eeca library:jms library:opensql common:library:com.sap.security.api.sda;library:com.sap.security.core.sda;library:security.class;library:webservices_lib;service:adminadapter;service:basicadmin;service:com.sap.security.core.ume.service;service:configuration;service:connector;service:dbpool;service:deploy;service:jmx;service:jmx_notification;service:keystore;service:security;service:userstore interface:resourcecontext_api interface:webservices interface:cross interface:ejbserialization sap.com/tcwddispwda sap.com/tcwdcorecomp service:webdynpro service:sld library:tcddicddicservices library:com.sap.aii.proxy.framework library:tcgraphicsigs library:com.sap.mw.jco library:com.sap.lcr.api.cimclient library:sapxmltoolkit library:com.sap.aii.util.rb library:com.sap.util.monitor.jarm library:tcddicddicruntime library:com.sap.aii.util.xml library:com.sap.aii.util.misc library:tc~cmi

Resources: /usr/sap/RW2/J00/j2ee/cluster/server0/apps/com.company.tv1/essfrayantdroit3/src.zip /usr/sap/RW2/J00/j2ee/cluster/server0/apps/com.company.tv1/essfrayantdroit3/webdynpro/public/lib/com.company.tv1essfr~ayantdroit3.jar

Loading model: {parent,references,local} -


Seems that it's a "negative cache" issue but I wonder how to solve it...

I found some posts about this: , and .

But I couldn't find my answer...

All I understand is that the "com.company.ayantdoit.models.zayantdroitgetascmodel.Zayantdroit_S" structure is defined twice on the server.

That would maybe be explained by the fact this DC has been duplicated in a new track, with the same name, and same package name. So we now have 2 DCs with the exact same name.

I tried undeploying this DC on the server (so it'd wipe everything out) and redeploying it with the latest version (the one from the new track) but it didn't change anything.

For information, I already tried to transport it again, but it didn't change anything.

Would someone have any idea ?

Edited by: Arnaud Leymet on Jun 30, 2008 1:14 PM