Skip to Content

BOE 4.2 users import from SAP BW issue

Hi everybody

I am facing an issue with SAP R3 users import on a BO 4.2

My environment is BO 4.2 SP3 on Suse Linux Enterprise version 11 patchlevel 3, with 16 CPUs and 64GB of RAM.

I configured 3 SAP entitlement systems: connection is ok and roles import is ok from all of them (I have the complete list of roles imported from SAP systems). R3 group creation is ok as well.

On this system, is also implemented note 1343537 to have users in simple name format and automatic join of all aliases of an user (note says to modify parameter "SimpleUsernameFormat"="Yes" in file /sap_bobj/data/.bobj/registry/64/softawre/sap businessobjects/suite xi 4.0/enterprise/auth plugins/secsapr3/.registry).

After an initial successful of “update roles and aliases”, now it doesen’t work anymore (clicking on “update now” or “schedule” as well): no new users are imported.

If I try to schedule the update job, it seems to run correctly (lasts 3 seconds) and ends with a “success” but nothing happens (no new user imported from SAP systems). I attach the log of this job (there is an error reported).

This is the second time I get this issue, in the previous case, I solved removing all imported roles, removing all entitlement system, deleting all imported users e reconfiguring everything.

Now I can’t do that anymore because users have stuff in their personal folders, and imported group are part of a gerarchy.

Nothing is changed on SAP systems nor in SAP users roles.

Please help me !

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

4 Answers

  • Oct 26, 2016 at 03:03 PM

    Some other info:

    I looked in SAP backend (Netweaver BW 7.01) for some trace: I can’t find NO activity made by the user coming from BO (analysis made with transaction STAD) when I try to update all users/roles.

    Othervise, if I try to logon to BO with a SAP user never logged before, logon is SUCCESSFUL, user IS CREATED and, in STAD, I find log about RFC connection from BO.

    It seems that something is wrong, in BO, with update button !

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Aug 15, 2017 at 09:00 AM

    Did you solve this issue?

    Add comment
    10|10000 characters needed characters exceeded

  • Aug 15, 2017 at 06:15 PM

    The version you mention has a regression https://apps.support.sap.com/sap/support/knowledge/preview/en/2388068 and needs to be patched to at least 4.2 SP3 patch 3

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Nov 03, 2017 at 01:17 PM

    Hi Andrea, Tim, all,

    I have experienced this kind of behavior (trying to synch SAP BW users to BO with a tested and working OLAP connection) on a very new Business Objects realse: 4.2 SP4 Patch 3.

    Strange thing is, that this is only happening on the newstest installtion of our 3-tier-system landscape.

    The other two systems of version 4.2 SP4 Patch 2 and 4.2 SP4 Patch 3 work correctly in terms of authentication and user synchronisation. All systems use the same setup and configuration.

    We will try the workaround of the note posted above and restart the BO machine as soon as we can have a downtime, but this does not seem like a permanent and stable solution.

    What do you think? Anything similar?

    Thank you,

    Marcus

    Add comment
    10|10000 characters needed characters exceeded