Skip to Content
avatar image
Former Member

User Default does not Work in GRC AC 10.1

Hello Experts,

I need you help with user default. I have already setup user defaults as per SAP Note

1665585 - User Defaults not applied to user in SU01

Also I have followed blogs to setup Loop for connector on decision table

https://blogs.sap.com/2014/10/07/user-defaults-grc-100/

I am not getting any error while activating ruleset, function, Loop, Decision table.

Decision table simulation gives correct result. However, User default is not getting reflected in plug in system. Even Request log says - "User attributes changed". I am attaching screenshot of my decision table, Loop and ruleset. Kindly let me know if anything is missing from my configuration?

function.pngdecision-table.png

ruleset.png

loop1.png

function.png (24.4 kB)
decision-table.png (28.9 kB)
ruleset.png (18.4 kB)
loop1.png (33.3 kB)
Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

7 Answers

  • avatar image
    Former Member
    Feb 16 at 09:37 AM

    Hi,

    Some of screenshots are already provided and I have couple of more.

    Yes, My decision table simulation shows correct value.

    Add comment
    10|10000 characters needed characters exceeded

  • Feb 16 at 06:18 AM

    Hello Sheenam,

    Could you please provide details/screen capture of User Default config. Also, do you get correct result while simulating whole BRF+ function ?

    Kind regards,

    Yashasvi

    Add comment
    10|10000 characters needed characters exceeded

  • Feb 20 at 03:36 PM

    Have you performed the SPRO configuration for this?

    Add comment
    10|10000 characters needed characters exceeded

  • Feb 21 at 07:55 AM

    Hello Sheenam,

    Pleas elet us know if simulation of BRF+ function (not Decision table) works fine. Also, please provide screen shots of SPRO configs for user defaults.

    Kind regards,

    Yashasvi

    Add comment
    10|10000 characters needed characters exceeded

  • Feb 27 at 06:43 PM

    Hi Sheenam,

    Did you copy the standard BRF+(User Defaults) and made changes or you created from scratch? What's the BRF+ function ID for user defaults.I hope you did the BRF+ mapping in SPRO?Are you able to see the see the usergroup inside the access request(in User Groups Tab)

    Thanks

    Ramesh

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Feb 28 at 11:03 AM

    screen2.jpg

    screen1.png

    result.pngHi,

    Yes BRF plus function gives correct result. Here are screenshots

    Add comment
    10|10000 characters needed characters exceeded

  • Mar 06 at 04:15 PM

    Sheenam,

    Use Connector instead of System in your DT and let us know if that fixed your issue.

    Thanks

    Ramesh

    Add comment
    10|10000 characters needed characters exceeded