Skip to Content
0

Unable to save custom attributes in BP_CENTRL to database

Feb 14 at 10:19 PM

71

avatar image
Former Member

Hi Experts,

I have extended the data model with custom attributes, below are the high level steps. however when i enter the value in that field and try to approve my CR. the values are getting lost/vanished -> not saving in database active tables.

  • create data element, domain
  • extend active structures with customer include - kna1, lfa1, cmds*central_data + cmds*central_data_xfield, vmds*central_data + vmds*central_data_xfield.
  • add attribute to data model bp_centrl , activate DM. Adjust staging.
  • generate DM specific structures
  • do mappings. BP_BP_CENTRL_2STA, BP_BP_CENTRL_2API
  • go to genil_model_browser , add in the key structure, attribute strcture.
  • add in UI and test

Is there anything i am missing here.

Thank you, Shaila.

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

3 Answers

Rohit Singh Feb 15 at 05:03 AM
0

Hi Shaila,

If you want to store the data in LFA1/KNA1 (for custom fields), then you need to extend the entity BP_VENGEN/BP_CUSGEN respectively & follow the same steps with Mapping under SUPPL_BP_VENGEN_2STA/MDG_BS_SUPPL_BP_VENGEN and similar for Customer.

Have a look at the Tutorial first:-

SAP How-To Guide: Extend MDG-S Data Model by a New Field (Reuse Option)

Cheers,

Rohit

Share
10 |10000 characters needed characters left characters exceeded
avatar image
Former Member Feb 16 at 04:19 AM
0

Thank you very much for link. i updated the CVI part which was missing, however it still does not help me save in db tables. my scenario is extend in bp/kna1/lfa1 all.

Share
10 |10000 characters needed characters left characters exceeded
Raghuram Reddy Devagiri Mar 07 at 04:00 PM
0

Hi ,

Check OSS note 2598879 - SMT mappings for custom fields are not getting populated after release upgrade

Regards,

Raghu

Share
10 |10000 characters needed characters left characters exceeded