Skip to Content
0
Former Member
Jun 23, 2008 at 06:30 PM

Database connector error:Unexpected when connecting to salesforce in CR2008

19 Views

ISSUE:: Unable to connect to salesforce in CR2008 as when he tries to select the table in the Database expert he gets an error 'Database connector error: Unexpected' however he is able to connect to salesforce and then select the tables using CR XI R2

Observed Behavior:

- The customer is able to connect to salesforce and then select the tables in CR XI R2 however when he tries to select the table through CR 2008 he gets an error 'Database connector error: Unexpected'.

- He does not have an issue switching Windows accounts. He can log in to Salesforce.com from Crystal Reports XIR2 and 2008 using a SFDC account with restricted access from my Windows account. However, he is not able to log in to SFDC using the system administrator SFDC account in Crystal Reports 2008, but is able to using Crystal Reports XIR2. This applies to the production and sandbox SFDC environment.

- He can update data on all reports using CR2008 if the report was created in CRXIR2. He cannot access any data from reports created with CR2008.

Expected Behavior:

- Should be able to select the tables and create reports based off it.

Steps to reproduce:

- Open Crystal Reports 2008 and then connect to salesforce with the credentials provided by the user i.e.

test.nussbaumer @cit.com.test

crystal2008

token: LxYbugxsVmGpRL1QOVIC2q0e '

This gives an error:

'Logon failed. Details: Unexpected Error; nested exception is java.net.UnknownHostException: www.salesforce.com

What has been done so far:

-Have tried the repair on CR 2008 but didn't help.

- The customer has tried some user credentials for a different user in his SFDC instance and was also able to login. He realized that only the system administrator is not able to login. Customer had sent the sample credentials for a test system administrator profile in his sandbox environment. (test.salesforce.com) , used that on my end to connect however it gave the error :'Logon failed. Details: Unexpected Error; nested exception is java.net.UnknownHostException: www.salesforce.com'

test.nussbaumer @cit.com.test

crystal2008

token: LxYbugxsVmGpRL1QOVIC2q0e

To access the Sandbox, he uses test.salesforce.com as the server when connecting with Cyrstal Reports 2008.

- He reset the password and received the same error. He can access Salesforce.com with CR XI R2, but not with CR2008.

- He set up a new computer with only JDK 1.4 on it, using Windows XP Professional and received the same error. His comments:

( I don't believe that this has anything to do with the JDK version, but rather with the size of the metadata in SFDC. If I login as the administrator, I receive the error in CR2008. However, as mentioned before, if I login as a standard user I am able to use CR2008.)

We tried resetting the User Security token by follwoing the below steps(A security token is not needed for login as I am using a trusted network by SFDC):

Steps for Resetting a User Security Token:

1.) To reset your security token, click Setup | My Personal Information | Reset Security Token, and click the Reset Security Token button. The new security token is sent via email to the email address on your Salesforce user record.

2.) You will need to login by entering your username and then your password + security token (without the +).

- Modified the CRConfig.XML file for the proxy server settings and then tried connecting to pull up the tables however still gave the same error.

Configuration:

Windows XP Professional 5.1.2600 SP2 Build 2600

CRXIR2 - 11.5.9.1076

CR2008 - 12.0.0.683

J2SE Development Kit 1.5.0.60

He is using JDK 1.6 (file: jre1.6.0_05). He tried installing JDK 1.4 and pointing to the file: jre1.4.2_17 but had no success.

Version 3 of the Crystal Reports for Salesforce.com driver

Sandbox environment

Edited by: Komal Prasad on Jun 26, 2008 5:28 PM

Edited by: Komal Prasad on Jun 26, 2008 5:29 PM