Skip to Content

Migration from local XS server to SAP Hana Cloud XS Server - Service layer problem

We have developed a fully functional XS app using service layer on our XS server (HANA MDC (<trial>) free version system). The certificate we assigned to the httpdest linking to our service layer works FINE in the environment of our company's HANA server.


However, when we uploaded the project to Sap cloud platfrorm xs server,only changed the Host of httpdest to but Public address of our service layer. The trust store certificate did not work. We tried to access the "globalIP:50000" and save a certificate that way but got same error. Meanwhile, the certificates do work on our system. The error we get looks like the certificate problem : "HttpClient.request: request failed: internal error occurred "Failed to send request to socket...rc = -1""


What might be the problem ? If anything helps, I can upload the screen shots or supply more details. Thank you

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Best Answer
    Feb 15 at 01:36 PM

    Hi Goga,

    It doesn't look like an issue with the certificate itself.

    Nevertheless, just to narrow the options, could you try to connect to your Service Layer using HTTP connection in the port 50001. If this didn't work the issue isn't the certificate.

    This error mostly happens when the destination host is wrong, you might check how the http client is receiving this info.

    Add comment
    10|10000 characters needed characters exceeded

    • Hello Ralph, thank you for this good advice, I did not know that 50001 port worked on http and without SSL certificate, otherwise I would have tried that. We will check the service from cloud xs server and will comment about the outcome here.