Skip to Content
0

webgui service does not display the SAP GUI screen

Feb 10 at 04:42 PM

222

avatar image

Hello all,

I am trying to test webgui ITS service from SICF on BW system:

/default_host/sap/bc/gui/sap/its/webgui. I tried to use test services, I get

SAP GUI login screen page after i used my user name and password successful. Somehow the scrren hangs and does not shows anything

I had :

Activate the mentioned services.

  1. /default_host/sap/bc/gui/sap/its/webgui
  2. /default_host/sap/public/bc/ur
  3. /default_host/sap/public/bc/its/mimes

AND:

Run T-Code SIAC_PUBLISH_ALL_INTERNAL to activate the services

I have find this error from SMICM log file:

(SI_ESYSCALL/10054; I4; ST) [nixxi.cpp 6217]
[Thr 17224] Thu Feb 08 12:19:32 2018
[Thr 17224] *** ERROR => IcmConnThSync: No OOB message received [icxxconn.c 4491]
[Thr 17224] *** ERROR => NiIShutdownHandle: SiShutdown failed for hdl 129/sock 14156
(SI_ESYSCALL/10054; I4; ST) [nixxi.cpp 6217]
[Thr 17220] Thu Feb 08 12:19:36 2018
[Thr 17220] *** ERROR => IcmConnThSync: N

Any help.

Thanks

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

5 Answers

avatar image
Former Member Feb 13 at 07:42 AM
0

Hello Reza,

We will need more detailed error message of the issue you are facing.

Meanwhile, check this threads if they will be useful: https://archive.sap.com/discussions/thread/1716844

https://wiki.scn.sap.com/wiki/display/HOME/ITS+Troubleshooting+Guide

Thank you.

Show 1 Share
10 |10000 characters needed characters left characters exceeded

Hello Oluwafemi,

Thanks for reply.

Please tell me what detail do you need. I have check this threads. I have the same issue.

Det differens is I get this error in SMICM:

(SI_ESYSCALL/10054; I4; ST) [nixxi.cpp 6217]
[Thr 17224] Thu Feb 08 12:19:32 2018
[Thr 17224] *** ERROR => IcmConnThSync: No OOB message received [icxxconn.c 4491]
[Thr 17224] *** ERROR => NiIShutdownHandle: SiShutdown failed for hdl 129/sock 14156
(SI_ESYSCALL/10054; I4; ST) [nixxi.cpp 6217]
[Thr 17220] Thu Feb 08 12:19:36 2018
[Thr 17220] *** ERROR => IcmConnThSync: N

I had follow this blog to check my configuration.

https://blogs.sap.com/2012/06/27/how-to-configure-web-gui-for-sap/

Thanks for any help

Br

Reza

0
Oisin ONidh
Feb 16 at 08:06 PM
0

Hi Reza,

this is an ICM error message

Can you increase the ICM trace level to 2 or 3 and recreate the issue and set trace back to 1 after?

Does this provide more detail on this

[Thr 17224] *** ERROR => IcmConnThSync: No OOB message received [icxxconn.c 4491]
[Thr 17224] *** ERROR => NiIShutdownHandle: SiShutdown failed for hdl 129/sock 14156


what are the results if your test the PING service

/sap/public/ping

Regards,

Oisin

Show 1 Share
10 |10000 characters needed characters left characters exceeded

Hello Oisin,

Thanks for reply.

I am happy still SAP forum is working.

The results of testting the PING service from : /sap/public/ping is (Server reached successfully

I get the same errors:

[Thr 17224] Tue Feb 20 15:33:39 2018
[Thr 17224] *** ERROR => IcmConnThSync: No OOB message received [icxxconn.c 4491]
[Thr 17224] *** ERROR => NiIShutdownHandle: SiShutdown failed for hdl 99/sock 17752
(SI_ESYSCALL/10054; I4; ST) [nixxi.cpp 6217]
[Thr 17208] Tue Feb 20 15:33:50 2018
[Thr 17208] *** ERROR => IcmConnThSync: No OOB message received [icxxconn.c 4491]
[Thr 17208] *** ERROR => NiIShutdownHandle: SiShutdown failed for hdl 102/sock 18696
(SI_ESYSCALL/10054; I4; ST) [nixxi.cpp 6217]

Thanks for any help.

BR

Reza

0
Zoe Li
Feb 23 at 07:30 AM
0

Hi Reza,

Which Basis and SP is your system on?

If you are on Basis 7.00 or 7.01, please add "~webgui_new_design" with value 1 to enable the new webgui design see if it works.

See Note 2108843 - When to use ~webgui_new_design?

Best Regards,

Zoe

Show 1 Share
10 |10000 characters needed characters left characters exceeded

Hi Zoe,

Thanks for reply.

We are in Basis 740 SP11.

Thanks

Reza

0
Isaias Freitas
Feb 26 at 08:35 PM
0

Hello Reza,

Please read the SAP Note 2213657 (S-user required) and ensure that all SICF services required for your release were enabled.

In addition, what browser you are using (Chrome, FireFox, Internet Explorer)? Have you tried with a different browser?

It would also help if you could provide an HTTP trace (SAP KBAs 1990706 or 1558903; S-user required).

Regards,

Isaías

Show 2 Share
10 |10000 characters needed characters left characters exceeded

Hello Isaias,

Thanks for reply, it is good to get help.

All SICF services required for your release were enabled

As I told we are on Basis 740 SP11.

This note are for Basis WebAS 7.00 or 7.01.

Thanks Reza

0

Hello Reza,

The SAP Note 2213657 (S-user required) has information as of Basis 7.00. It covers 7.40 and even 7.50 ;-).

Regards,

Isaías

0
Cristiano Hansen
Mar 01 at 02:28 PM
0

Hello Reza,

Publishing the WEBGUI service will not help. This is no longer necessary, as the WEBGUI now uses the mimes from the kernel (inside ITS.SAR, that is extracted by the ICM process).

Please check whether KBA 2234414 (https://launchpad.support.sap.com/#/notes/2234414) helps - even though you might not face the issue described there.


Regards,

Cris

Show 2 Share
10 |10000 characters needed characters left characters exceeded

Hello Cris,

Thanks for reply,

It did not help,

We try to use the latest Kernel and see this will helps.

Thanks Reza

0

Hi Reza,

Check whether there are error messages in dev_icm. See also whether the ICM process called sapcar to extract the ITS.SAR package.

You also can use the browser developer tools to check whether there are missing files (404 HTTP errors) or other messages that can point why the WEBGUI service doesn't work.

Kind regards,

Cris

0