Skip to Content

hana express (VM) Tutorials : Package.json dependencies "latest" version

Hello

I am trying the Hana Express tutorials.

In the package.json, some dependencies are "latest" as version number. it causes errors during the build.

How set the VM environment to take into account the command "latest" ?

Regards

Emmanuel

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Best Answer
    Oct 26, 2016 at 12:45 PM

    What kind of errors are you having? The latest version should work as the npm command ran internally by the build/deploy should first check you local npm repository within the HANA system itself (service di-local-npm-registry) and then check the upstream NPM (http://registry.npmjs.org/). Perhaps your system is behind a firewall/corporate proxy and you didn't configure the proxy settings for the di-local-npm-registry. You can issue an xs env di-local-npm-registry to see what the settings are for this service. You can also use the xs set-env command to change the values. Just remember to restage and restart the service afterwards.

    Add comment
    10|10000 characters needed characters exceeded

  • Oct 28, 2016 at 03:01 AM

    Hello Thomas.

    First, I would like to thank you for the Hana openSap courses.

    In the Hana Express VM, there is no UPSTREAM_LINK defined.

    I have set the following settings. (thanks to the thread https://archive.sap.com/discussions/thread/3921267 and sorry for the duplicate)


    Thanks a lot

    Regards

    Emmanuel

    Add comment
    10|10000 characters needed characters exceeded