Skip to Content

Crystal reports Server - Database properties are not considered when Crystal Report is called

Hi all!

When I open a Crystal report in the Central Management Console (or with openDocument) the stored database configuration seems to be not considered.

When I schedule the report it works fine. Is there any parameter to be set or anything else that the stored database credentials are used when a report is called?

I have installed the Crystal Reports Server 2016 trial edition. I tried it with an database connection to SAP Netweaver and an Oracle database. I tried it also with both options: the original database credentials and the user-defined database credentials option.

Sorry for the german screenshots, but I installed the German version only.

Thanks in advance, Andreas

Add a comment
10|10000 characters needed characters exceeded

Related questions

1 Answer

  • Best Answer
    Posted on Feb 12, 2018 at 02:31 PM

    There are a couple of options at the top when you set up the database credentials. In the English version, the label for the second drop-down at the top says "When viewing and scheduling the report:". You need to select the option that translates to "Use same database logon as when report is run". The SSO option that you've selected is trying to use SAP SSO to log the current user into the system, which won't work unless you have SAP authentication enabled and configured to do SSO. You'll chose the same option for the Oracle report as well.

    -Dell

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.