Skip to Content
0

Restore UJBR error ORA-00942

Feb 10 at 07:05 PM

51

avatar image

Hi BPC experts!

SAP_BW 740, CPMBPC 801 SP-level 10

I have some problem with restoring in UJBR. I'm trying restore from PROD to DEV. UJBR give me error "SQL message: ORA-00942: table or view doesn't exist". I restore in Background mode because my backup about 2Gb(without data). I did not find any sap note.

ujbr.jpg (61.0 kB)
error.png (30.9 kB)
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

5 Answers

Vadim Kalinin Feb 10 at 08:50 PM
0

If you are using "Insert File" instead of "Insert Image" then:

1. You are not reading forum (I have told many times not to do it).

2. No answers from me.

P.S. And version/SP info about BPC and BW is not provided clearly!

Share
10 |10000 characters needed characters left characters exceeded
Vadim Kalinin Feb 11 at 08:22 AM
0

Do you restore backup over existing environment?

Do you have the same BW/BPC SP level on PROD and DEV?

P.S. CPMBPC 801 SP-level 10 is VERY old!

Show 1 Share
10 |10000 characters needed characters left characters exceeded

Of course not, I deleted existing environment, PROD and DEV same SP level.

0
Peter KREUTLEIN
Feb 11 at 03:12 PM
0

You are using the option "use technical names from backup files" to restore the Environment with the same technical names as in your Productive system.

UJBR does not restore to an already existing environment. If restoring to an existing environment with the same technical names you need to fully delete the existing environment and all references to any technical objects.

It can happen that deleting an environenment witll not delete all references to tables (due to dependencies, etc). There is a program UJAA_CLEAN_DELETED_APPSET that can be used to remove any orphaned references, but this program does not exist in your SP version which as Vadim has stated is quite old. You would need at minimum SP13 for this program.

Ad the short dump message clearly states the table name in question, please delete the existing environment you are trying to restore into and ask your BASIS to search for any reference to this table and remove it and try your restore again.

Regards,

Peter Kreutlein

Show 2 Share
10 |10000 characters needed characters left characters exceeded

Thanks for your answer, sure I deleted existing environment, I cleared all value according to old environment from tables which are listed by program UJ0_GET_GEN_TABNAME

0
Amirkhan Kozhageldiyev

UJAA_CLEAN_DELETED_APPSET will delete all related tables.

UJ0_GET_GEN_TABNAME is for different thing.

0
Amirkhan Kozhageldiyev Feb 11 at 06:37 PM
0

So BPC experts as I understand the solution is I must upgrade SP level up to minimum SP 13?

Show 1 Share
10 |10000 characters needed characters left characters exceeded

Not bad idea in general - upgrade to the latest!

0
Peter KREUTLEIN
Feb 11 at 10:54 PM
0

I would strongly suggest upgrading to the latest SP and keep current with new releases on a fairly frequent basis. keep in mind that code fixes are normally only provided for the latest SP and last three releases, so if any new code related issues were discovered that impacted your system we would not fix it in your SP.

As this issue has shown, being too far behind means that fixes and features that are released to fix issues will not be available for your SP.

Share
10 |10000 characters needed characters left characters exceeded