Skip to Content
0

WebdynPro - 503 service unavailable - Netweaver 7.5 (SP09) ABAP

Feb 09 at 11:47 PM

563

avatar image
Former Member

Hello,

I am new to SAP, and have run into a bit of a issue.

I am trying to get WEBGUI and WebdynPro configured

I have followed SAP's guide for setting up webdynpro - https://help.sap.com/viewer/7b44f2a7728810148a4b1a83b0e91070/7.5.9/en-US/4b28c1d578af31cce10000000a42189c.html

However when I try accessing it i get the error 503 - Service not available:

I have the following installed on the SAP ABAP system:

One thing I have noticed is that if I roll back the system before 'SAP SRM ON ERP' is installed the settings work, however this add-on is going to be needed on this system, but currently no configuration for it has been done yet.

I would really appreciate any assistance on this...

Thank you in advance..

503.jpg (7.9 kB)
sap.jpg (66.8 kB)
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

5 Answers

Best Answer
avatar image
Former Member Feb 20 at 10:29 PM
0

Hi All ,


I managed to figure it out..

My icm/server_port_(X) declaration was accidentally made in the instance profile and not the Default profile, moving it to the Default and restarting the services fixed the problem.

Thank you to eveyone for the assistance.


Regards

Sharanpal Ghataura.

Share
10 |10000 characters needed characters left characters exceeded
saharoon musathick Feb 12 at 06:46 AM
0

Hi Sharanpal Ghataura,

1.Please check your ICM is active

Goto SMICM Goto --> Service

2 . Tcode SICF and make sure the following tress are activated (If not activate those services)

  1. /default_host/sap/bc/gui/sap/its/webgui
  2. /default_host/sap/public/bc/ur
  3. /default_host/sap/public/bc/its/mimes

3,Run T-Code SIAC_PUBLISH_ALL_INTERNAL to activate the services

Regards,

saharoon.s


Share
10 |10000 characters needed characters left characters exceeded
Bruno Garcia Feb 13 at 11:07 AM
0

Hi Sharanpal,

If you use Google Chrome, can you open the developer tools by hitting F12 and then try to load your URL.
Then in developer tools go to 'Network' tab and find the HTTP call that corresponds to status 503. You should be able to get the missing service from there.

See if this helps you a little more.

Kind regards,
Garcia

Show 3 Share
10 |10000 characters needed characters left characters exceeded
Former Member

Hi Garcia,

Thank you for the tip, using this it would seem that favicon.ico is the service that it cannot find:

I now need to work out where this service is located..the following have been enabled:

default_host > SAP > Public > bc > icons

default_host > SAP > Public > bc > icons_rtl

kind regards

Sharanpal Ghataura

favicon.jpg (17.6 kB)
0

Hi Sharanpal,

Aren't you able to find more services like that? Check inside the "network" tab where you can get all HTTP calls instead of the console.

Normally, the favicon.ico is not a showstopper. If you search in marketplace there are some notes about it.

Kind regards,
Garcia

0
Former Member

Hi Garcia,

Network tab gives me pretty much the same information, nothing additonal on favicon.

regards

Sunny

0
avatar image
Former Member Feb 12 at 08:32 PM
0

Hi saharoon,

Thank you for your feedback, I can confirm that ICM is active in SMICM:

In SICF the following are active:

  1. /default_host/sap/bc/gui/sap/its/webgui

  1. /default_host/sap/public/bc/ur

  1. /default_host/sap/public/bc/its/mimes

running Run T-Code SIAC_PUBLISH_ALL_INTERNAL to activate the services also completes without erorr, but I still get the 503 - Service not available error

I am using the following URL: http://<sapserver host>:8000/sap/bc/gui/sap/its/webgui?sap-client=800

Any other thoughts?

Thanks

Sharanpal


icm.jpg (36.9 kB)
webgui.jpg (16.0 kB)
ur.jpg (29.6 kB)
its.jpg (41.4 kB)
Share
10 |10000 characters needed characters left characters exceeded
saharoon musathick Feb 13 at 08:20 AM
0

Hi Sharanpal Ghataura

I can see you are using following URL for webgui http://<sapserver host>:8000/sap/bc/gui/sap/its/webgui?sap-client=800

1.Did you tried ip instead of your hostname,sometime DNS will not resolve the host name properly (

http://<sapserver ip>:8000/sap/bc/gui/sap/its/webgui?sap-client=800) if you are using ip your URL will look like (

http://<192.168.1.0>:8000/sap/bc/gui/sap/its/webgui?sap-client=800)

2.Try maintain your host file which is located in C:\Windows\System32\drivers\etc

Regards,

saharoon.s

Show 1 Share
10 |10000 characters needed characters left characters exceeded
Former Member

Hi,

Using IP gives the same result.

Regards

Sharanpal

0