Skip to Content

IDT - Limit Execution time does not work

Hi,

I am a bit confused about the behaviour of the parameter "Limit execution time" on a universe designed on IDT. In the below sample we set up the parameter to 10 minutes

After that we have created a webi document with a data provider based on this universe (Limits were not checked at query level)

. As we know that the execution of the report could take a siginificant time we scheduled it. See below the results of the schedule execution.

Report execution scheduled was success but it did take 2548 seconds! this value largely exceeds the 600 seconds (10 minutes) that we set up on the universe.

My question is: Should not the report execution stop after query execution time exceed the limit of 600 seconds (10 minutes) we set up at Universe level? Did I misunderstand something?

Thanks,

Alfons

kk1.png (5.6 kB)
kk2.png (7.7 kB)
kk3.png (13.2 kB)
Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Feb 09 at 10:27 AM

    what is your back end database?

    check in the database specific SBO file and see if "Query TimeOut Available" parameter is set to No or yes.if it's no then update to Yes and try.

    Also update the parameter in datafederator.sbo.

    Location

    C:\Program Files (x86)\SAP BusinessObjects\SAP BusinessObjects Enterprise XI 4.0\dataAccess\connectionServer\odbc

    Add comment
    10|10000 characters needed characters exceeded

    • Hi Amit,

      The target database is a SQL Server 2014.

      I have checked the file

      D:\BO\SAP BusinessObjects Enterprise XI 4.0\dataAccess\connectionServer\odbc\sqlsrv.sbo

      and I have found the parameter set to yes (see below)

          <Defaults>
              <Parameter Name="Family">Microsoft</Parameter>
              <Parameter Name="SQL External File">sqlsrv</Parameter>
              <Parameter Name="SQL Parameter File">sqlsrv</Parameter>
              <Parameter Name="Description File">odbcsso</Parameter>
              <Parameter Name="Strategies File">sqlsrv</Parameter>
              <Parameter Name="Driver Capabilities">Query,Procedures</Parameter>
              <Parameter Name="Extensions">sqlsrv,odbc</Parameter>
              <Parameter Name="Array Fetch Available">True</Parameter>
              <Parameter Name="Array Bind Available">True</Parameter>
              <Parameter Name="Empty String">EmptyString</Parameter>
              <Parameter Name="CharSet Table">odbc</Parameter>
              <Parameter Name="Query TimeOut Available">True</Parameter>
              <Parameter Name="Quote Identifiers">False</Parameter>
              <Parameter Name="Optimize Execute">True</Parameter>
              <Parameter Name="Use DataDirect OEM Driver" Platform="Unix">No</Parameter>
      <Parameter Name="Force Execute">Always</Parameter>
          </Defaults>


      Any other idea ?

  • Feb 09 at 12:05 PM

    Depending on the database, the query limit time may only be activated after the first batch of results is returned.

    Add comment
    10|10000 characters needed characters exceeded