Skip to Content
author's profile photo Former Member
Former Member

BRCONNECT fails with SQL error -942 at location ora_vers_get-1

BR0801I BRCONNECT 6.40 (34)

BR0280I BRCONNECT time stamp:

BR0301E SQL error -942 at location ora_vers_get-1

ORA-00942: table or view does not exist

BR0303E Determination of RDBMS version failed

BR0280I BRCONNECT time stamp:

BR0301W SQL error -942 at location brc_dblog_open-1

ORA-00942: table or view does not exist

BR0324W Insertion of database log header failed

BR0806I End of BRCONNECT processing: cdvvpgqj.log2007-

BR0280I BRCONNECT time stamp:

BR0804I BRCONNECT terminated with errors

External program terminated with exit code 3

BRCONNECT returned error status E

The same command if I am executing from CMD line, it runs fine, but only through DB13 it gives me the problem. I have just applied the note : 400421.

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

2 Answers

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Jun 18, 2008 at 12:19 PM

    DB13: External program terminated with exit code 1/2

    SAP Note Number: 437648

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Deepak,

      Thanks for the reply. Actually that note is of no use to me becuase I have mess up with note no. 400241.

      If I run the command of brconnect -u/ -c -f stats -t ALL, it run successfully. Only through DB13 it is having problem,

      I think I am confused with the owner of SAPUSER and T000 in the query of note 400241.

      select owner from dba_Tables where table_name='T000'

      returns SAPDEV

      select owner from dba_Tables where table_name='SAPUSER'

      returns OPS$SANDBOX\SNXADM( done a system refresh)

      SELECT OWNER, TABLE_OWNER, TABLE_NAME FROM DBA_SYNONYMS

      WHERE SYNONYM_NAME = 'SAPUSER';

      return

      OPS$SANDBOX\SAPSERVICESNX OPS$SANDBOX\SNXADM SAPDEV

      synonyms also okay

      OPS$SANDBOX\SAPSERVICESNX sap

      I doubt if there is any problem with OPS$ mechanism autho.... But I have alreay given select, update, resource to OPS$SANDBOX\SAPSERVICESNX

      Any idea what might be the problem?

  • author's profile photo Former Member
    Former Member
    Posted on Jun 19, 2008 at 09:05 AM

    I have run the saprole_dba.sql and things are working properly know. In the log I could found that all the grants failed

    But even though DB13 is working. I do not know how???

    Thanks Deepak for the note which took me to different notes and thought of running the .sql

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.