Skip to Content
author's profile photo Former Member
Former Member

Replace . with ,

Hi,

how to replace . with , in a quantity field?

many thanks!!!

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

8 Answers

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Jun 18, 2008 at 08:22 AM

    Hi,

    Try with 'REPLACE ALL OCCURRANCES OF' statement.

    remember this REPLACE will work only on CHARACTER fields. So you need to use write to statement before using REPLACE statement.

    data : char_qty type char18.

    write wa_mara-qty to char_qty.

    now you can use REPLACE statement.

    thanks & regards

    Kishore Kumar Maram

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jun 18, 2008 at 08:18 AM

    Hi,

    REPLACE '.' WITH ',' INTO in_par-value.

    Thanjks

    Vikranth

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jun 18, 2008 at 08:19 AM

    Hi,

    REPLACE { section_of | sub_string_in } dobj WITH new

    Reward pts if usefull.

    Regards,

    Dhan

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jun 18, 2008 at 08:20 AM

    Hi,

    Eg : V_Quanty = 9.99.000

    Replace all occurance of '.' in v_quanty with ','.

    Thanks

    Vikranth

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jun 18, 2008 at 08:20 AM

    hi,

    go to transaction su3.there in the defaults tab u will have an option called decimal notation.change the as u wish by drop button over there.

    i think this willl help u.

    please reward me if helpful.

    reagards,

    Reddy.

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jun 18, 2008 at 08:21 AM

    I have a quantity field....no char!!!

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jun 18, 2008 at 08:23 AM

    Hi,

    You could try using the 'TRANSLATE' keyword.

    Hope it works,

    Sandeep.

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Jun 18, 2008 at 08:34 AM
    TRANSLATE <Ur_firld> USING '.,'.

    Amit.

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.