Skip to Content

Ready/Not ready buttons are not visible in Interaction Center

Hi everyone,

I facing a not very common issue as far as I seen. I've configured SAP BCM/CCtr integration with SAP CRM several times and never saw this before. Ready/Not ready buttons are not being displayed in Interaction Center at all as its shown in this image:

Analizing the problem in deep:

Systems are SAP CCtr (Windows Server 2016) and SAP CRM EhP4

Configuration is already done in both CCtr and CRM systems as described in the document provided by SAP (

In order to test I copied the standard IC_AGENT business role and the only difference is I changed parameter CONTACT CENTER from empty to the configuration I did:

In the other hand, the integration itself is working fine, I can dial a number in Interaction Center and call without problems but once I try to finish the contact I get an error:

Then the Interaction Center screen is showing the same error and the counter keeps running. Once again if I try to call to another number it works fine but the screen keeps showing the same information of previous call.

Please let me know any idea, hint or theory about it, I want to be absolutely sure everything is properly configured before take other actions like massaging to SAP.

Thanks in advance.

ic1.png (32.7 kB)
ic2.png (25.9 kB)
ic3.png (24.6 kB)
Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Feb 09, 2018 at 11:37 AM

    Hi Emilio,

    I can see several issues here. One is related to telephony buttons and the other is related to alert messages.

    For the first one, I would recommend you to check KBA 2108228 and follow ALL steps from section

    "How to test communication channels using standard SAP configuration"

    Check KBA:1836437 CRM IC: How to set up an IC Agent role - technical prerequisites from customizing point of view to prevent errors

    For the second one, check if all mandatory SICF services are active for your SAP CRM (1295006) and depending on your SAP CRM version, you can change to APC (ABAP Push Channel). See KBA

    1822577 - How to set up polling free alerts to reduce network traffic

    Best regards


    Add comment
    10|10000 characters needed characters exceeded

  • Feb 22, 2018 at 08:51 PM

    Hi Emilio,

    we have encountered similar problem once we have started using HTTPS - the error message about alert was our clue. Do you use HTTPS for webui?

    Try to set parameter according to OSS note:

    1686114 - CRM-IC: SAM Session Communication; HTTPS does not work



    Add comment
    10|10000 characters needed characters exceeded