Skip to Content
avatar image
Former Member

Idoc's delay and stuck

Hello everybody,

I have a strange situation and if anybody can help me would be really appreciated, I have the next scenario:

R/3_1 Idoc-> XI -> R/3_2 Idoc

now the problem is that sometimes idocs get stuck in R/3_1 and even when WE02 indicates green status for sent idoc, XI is not receiving this Idoc at least not visible in SXMB_MONI, but if I try in the R/3_1 with WE19 to sent a copy of the idoc, suddenly XI receive both idocs, original that was stucked and new copy, can anyone tell any suggestions to check configuration in the R/3 to see why can this be happening?, thanks in advance.

Regards,

Julio Cesar

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

7 Answers

  • Jun 17, 2008 at 06:23 PM

    Check the SM58 transaction befor you send another idoc.

    The queues might have got stuck first time and later reprocessed in your R/3_1 system.

    Regards,

    Ravi

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jun 17, 2008 at 11:58 PM

    chck sm58 and chck whether in the partner profiles you are using send immediately or collect idocs .

    Edited by: Pramod Yadav on Jun 18, 2008 1:58 AM

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jun 18, 2008 at 02:31 AM

    Go through the below:

    1. SM 58 and verify any logs

    2. In the partner profile settings, trigger immediately IDOC should be checked.

    3. Also do CACHE refresh in XI once

    Thanks

    Kiran

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jun 18, 2008 at 05:40 AM

    Hi Julio Cesar,

    There are two ways in which an idoc can reach XI from R/3.

    The two output modes are :

    1.Transfer Idoc immediately - used when the idoc needs to reach XI immediately once triggered from R/3.

    2.Collect Idocs - used when the idoc doesn't need to reach XI immediately once triggered from R/3 but rather wait for some more idocs to be triggered so that all the triggered idocs are collected and all these collected idocs will reach XI at the same time.

    This output mode is specified in Partner profile(WE20)>Outbound Options of ur Idoc msg type >Output mode.

    See that it "Transfer Idoc immediately" is selected.

    Reward points if found useful.

    Thanks,

    Laawanya

    Edited by: Laawanya Danasekaran on Jun 18, 2008 7:41 AM

    Edited by: Laawanya Danasekaran on Jun 18, 2008 7:43 AM

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jun 19, 2008 at 10:08 PM

    The idocs in we20 are configured as processing immediatly, do you think the SXMB_ADM manage Queues registration and activation could be a problem in the R/3's?????

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jul 09, 2008 at 04:45 PM

    For update, XI is returning an empty AUDIT idoc, I think this is causing the problem but I can't find why XI is returning this Idoc automatically.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Sep 22, 2010 at 02:01 AM

    Hi, we deactivated the akcnowldge for the idocs in sap pi.

    Add comment
    10|10000 characters needed characters exceeded