Skip to Content
0

Version of node for kapsel sdk 16

Feb 07 at 12:35 PM

39

avatar image
Former Member

Can anyone know which version of cordova should i install alogn kapsel sdk 16

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Jitendra Kansal
Feb 07 at 12:55 PM
0

Khurshid Ansari

Please read here https://blogs.sap.com/2016/10/20/getting-started-kapsel-part-1-sp13/

Cordova 7.0.1 should be used if using SMP 3.0 SP16 SDK

Regards

JK

Show 2 Share
10 |10000 characters needed characters left characters exceeded
Former Member

Yes I found that I have to install 7.0.1 but I am getting error.

I have posted error

ERROR:

The build script exited unexpectedly!

No config file specified. Searching for config.json in the current directory. Config file found at D:\Khurshid\SAP_HAT_local-1.28.2\WebIdeCompanion\companionapp/config.json. platforms: android@6.2.3 7.0.1 cordova version: 7.0.1 Creating WebIdeCompanion project. Warning: --copy-from option is being deprecated. Consider using --template instead. Creating a new cordova project. D:\Khurshid\SAP_HAT_local-1.28.2\WebIdeCompanion\companionapp\CompanionApp D:\Khurshid\SAP_HAT_local-1.28.2\WebIdeCompanion\companionapp Adding platforms... android@6.2.3 Using cordova-fetch for cordova-android@6.2.3 Adding android project... Creating Cordova project for the Android platform: Path: platforms\android Package: com.sap.ide.companion Name: WebIdeCompanion Activity: MainActivity Android target: android-25 Subproject Path: CordovaLib Android project created with cordova-android@6.2.3 Discovered plugin "cordova-plugin-whitelist" in config.xml. Adding it to the project Installing "cordova-plugin-whitelist" for android This plugin is only applicable for versions of cordova-android greater than 4.0. If you have a previous platform version, you do *not* need this plugin since the whitelist will be built in. Saved plugin info for "cordova-plugin-whitelist" to config.xml --save flag or autosave detected Saving android@~6.2.3 into config.xml file ... Adding CompanionApp plugins... Error: Invalid Plugin! ..\plugins\toolbar needs a valid package.json cmd error The node process of the build script exited with code 1. No config file specified. Searching for config.json in the current directory. Config file found at D:\Khurshid\SAP_HAT_local-1.28.2\WebIdeCompanion\companionapp/config.json. platforms: android@6.2.3 7.0.1 cordova version: 7.0.1 Creating WebIdeCompanion project. Warning: --copy-from option is being deprecated. Consider using --template instead. Creating a new cordova project. D:\Khurshid\SAP_HAT_local-1.28.2\WebIdeCompanion\companionapp\CompanionApp D:\Khurshid\SAP_HAT_local-1.28.2\WebIdeCompanion\companionapp Adding platforms... android@6.2.3 Using cordova-fetch for cordova-android@6.2.3 Adding android project... Creating Cordova project for the Android platform: Path: platforms\android Package: com.sap.ide.companion Name: WebIdeCompanion Activity: MainActivity Android target: android-25 Subproject Path: CordovaLib Android project created with cordova-android@6.2.3 Discovered plugin "cordova-plugin-whitelist" in config.xml. Adding it to the project Installing "cordova-plugin-whitelist" for android This plugin is only applicable for versions of cordova-android greater than 4.0. If you have a previous platform version, you do *not* need this plugin since the whitelist will be built in. Saved plugin info for "cordova-plugin-whitelist" to config.xml --save flag or autosave detected Saving android@~6.2.3 into config.xml file ... Adding CompanionApp plugins... Error: Invalid Plugin! ..\plugins\toolbar needs a valid package.json cmd error The node process of the build script exited with code 1.

0
Former Member

Why sap recommending cordova 6.5.0

0