Skip to Content
author's profile photo Former Member
Former Member

QM02 notification task deletion autorization to be removed

I have a requirement as follows

Steps for reconstruction:

Tx: QM02

enter " notification" number

select task (TAB)

select the task listed

Now this task deletetion autorization needs to be removed. ie the user must not have this authorization.

Is there any way to hide the deletion button . I want to use only authorization and not screen variants

I checked almost all object having "task " in its despcribtion.

Edited by: Hussain Sehorewala on Jun 17, 2008 4:25 PM

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

3 Answers

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Jun 17, 2008 at 09:12 PM

    Hi,

    If you are asking for the deletion flag then you can set or deselect in the

    QM02->notification->tasks goto Notification->functions->Deletion flag

    I have run trace for the same its showing object Q_GP_CODE with catalog 02(tasks) and code group QM-1.Deactivate the object run QM02 and try to delete the task.

    Rakesh

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jun 17, 2008 at 05:13 PM

    Try this:

    Object:

    B_NOT_TASK: Access to Tasks in General Notifications

    Activities:

    11: Displaying a task in the task transaction and in task worklists

    12: Displaying a task in the task transaction and in task

    worklists, if the user is assigned to the task as the processor

    (partner for the task).

    21: Processing a task in the task transaction

    22: Processing a task in the task transaction, if the user is

    assigned to the task as the processor (partner for the task)

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jun 17, 2008 at 05:49 PM

    Hi,

    Get the objects(for which proposal is YES) from su24 for the transaction QM02 .

    Try by unchecking the Delete option in ACTVT for the above objects.

    (It may be solved by trial and error)

    Regards,

    Ajit.

    Edited by: Ajit Nadkarni on Jun 17, 2008 7:50 PM

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.