Skip to Content

Error when adding HANA Views to RTC CompositeProv

Feb 06 at 04:33 PM


avatar image

Hello Experts,

We are implementing a RTC solution for the first time and we are getting this error message during the creation of the CompositeProv (used to join VirtualProvider and RTC model views): "Error when getting results: insufficient privilege: Not authorized". (See image below).

In a previous forum the same error was solved, however, our Basis applied the solution indicated and the error remains:

We are working in 1610 FSP02 (with BW 7.5.1 SP 2, BPC 10.1). We got the same error either in HANA Studio and in Eclipse.

Could you please, help us?

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Daniel Valle Feb 21 at 05:06 PM

Hi Bibiana,

I had the same issue, it's very easy to solve.

You need to authorize some Privileges to SAPABAP1 database user to be able adding SAP HANA views when you create a composite provider.

and then, you need to give this privileges:

and this too:


Daniel Valle

sapabap1.jpg (106.4 kB)
sysrepo.jpg (108.9 kB)
active-object.jpg (65.6 kB)
10 |10000 characters needed characters left characters exceeded