Skip to Content
author's profile photo Former Member
Former Member

HTTP Error

Hi, In one of my idoc to file scenario I am getting the below error in SXMB_MONI,

Please can someone help me to troubleshoot it.

HTTP response contains status code 503 with the description Service Unavailable Error while sending by HTTP (error code: 503, error text: Service Unavailable

regards

Reema

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

5 Answers

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Jun 17, 2008 at 08:04 AM

    Hi,

    Refer, the below links may help you

    HTTP Errors in XI

    Question 8 discusses the problem and things to be checked

    /people/krishna.moorthyp/blog/2006/07/23/http-errors-in-xi

    Please take a look at this..

    503 service unavailable

    XIServer error raised: 503 Service Unavailable with SOAP Adapter

    /people/krishna.moorthyp/blog/2006/07/23/http-errors-in-xi

    OR

    The problem may be due to Adapter FrameWork

    You can restart the J2EE Engine from transaction SMICM:

    SMICM --> Administration --> J2EE-Server --> Send Hardshutdown or Softshutdown --> with restart

    Thanks

    Swarup

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jun 17, 2008 at 08:04 AM

    Hi,

    503 Service unavailable

    this is because of the server is currently unable to handle the request due to a temporary overloading or maintenance of the server. The implication is that this is a temporary condition which will be alleviated after some delay. If known, the length of the delay MAY be indicated in a Retry-After header. If no Retry-After is given, the client SHOULD handle the response as it would for a 500 response.

    Note: The existence of the 503 status code does not imply that a server must use it when becoming overloaded. Some servers may wish to simply refuse the connection.

    you can go for the possible solution as mentioned below:

    Because of J2EE application com.sap.aii.af.ms.app not active

    1. Try to (re)start the application using the Visual Administrator Choose Server --> Services --> Deploy --> View on Application or restart the J2EE engine.

    2. The problem is that not all J2EE services can be started by the J2EE. i.e Start the Visual Administrator and select Server->Services->Deploy in the tree on the left. On the right-hand side, choose the Runtime tab page. You see a tree in the right window with all applications if you select the APPLICATION radio button. Check if they are running, otherwise choose Start. Usually the J2EE engine starts all services automatically.

    3. Refer SAP Note 803145,807000,791655

    4. In Visual Admin, check if all the required services are running and start them, else restart the Java Stack in the XI server.

    /people/krishna.moorthyp/blog/2006/07/23/http-errors-in-xi /people/vinoth.murugaiyan/blog/2007/08/06/how-to-the-change-the-application-stopped-message

    http://help.sap.com/saphelp_nw04/helpdata/en/64/351941edd5ef23e10000000a155106/frameset.htm

    Thanks,

    Vijaya.

    Edited by: Vijaya Lakshmi Palla on Jun 17, 2008 4:05 AM

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jun 17, 2008 at 08:03 AM

    Hi,

    Do a complete Cache refresh.

    Might be becaue of Cache problem

    Go to transaction SXI_CACHE.

    Double Click on Services.

    On the right had side check if the sender & receiver service which you are using in the current scenario is present.

    If not present do a complete cache refresh using menu

    XI Runtime Cache ->Start Complete Cache Refresh

    and also using browser..

    http://xiserver:j2eeport/CPACache/refresh?mode=full

    Thanks

    Vikranth

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jun 17, 2008 at 08:05 AM

    Hi,

    Check this link,

    503 service unavailable

    Thanks

    Vikranth

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Jun 17, 2008 at 08:16 AM

    Hi Reema,

    Check out this blog by Prashanth. It clearly explains various errors and their reasons. It might be helpful:

    /people/prashanth.azharuddin/blog/2006/11/24/some-errors-in-an-xi-production-environment

    Regards,

    Sanjeev.

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.