Skip to Content

Bex Variable Prompt - Missing variable field

Hi Folks,

I am on BI4.2_SP3 / DS1.6_SP2P1


On BI-Launchpad - Calling bex optional prompt, i see dialog-box for prompt but not variable field.

DS Local Execution - It works as expected.

Possible solution?

Upgrade BI version? - speaking of that, i recently upgraded sanbox with sp5, I could have tested there but need to built the query in there first. Please let me know your thoughts.

Please find screenshots attached to my post.

Appreciate your suggestions.






prompts01.png (10.9 kB)
prompt-local.png (35.8 kB)
Add a comment
10|10000 characters needed characters exceeded

  • Could it be a browser issue? Have you tried multiple browsers? SP2 is really old for 1.6, any chance you could try with SP6 for Design Studio?

  • Hi Tammy,

    Thanks for your advice, I'll definitely upgrade to SP6 sometime today or tomorrow to Dev system (as i upgraded sandbox to BI4.2 SP5 with Lumira 2.0 few weeks back).

    Yup IE10/Chrome/Firefox all with same issue.

    Meanwhile this is what i did.

    • Created new OLAP connection in sandbox(BI4.2_SP5 + Lumira 2.0) and pointed to SAP-BWD (query location).
    • Upload existing application with DS1.6_SP2 import option to sandbox(BI4.2_SP5 + Lumira 2.0).
    • Run application on Sanbox.
    • It worked (Please see attached here promptsbi42-sp5.png).

    Now the question is what fixed it? BI4.2_SP5 or the Lumira2.0 :-)

    I believe once I upgrade to SP6 like you advice, will get some answers here.

    promptsbi42-sp5.png (162.7 kB)
  • Hi Tammy,

    Client requested for some work around to resolve the issue, therefore decided to built one prompt dialog-box with easy (css + Dimension Filter) and passed though setVariableExt to all data-source. Screenshot here.prompt3.png

    Did some investigation on the issue and attached is some observation. I might be able to solve it, struggling with some classes though. Its basically the white section overlaying prompts field. Screenshot here.prompt4.png



    prompt3.png (19.4 kB)
    prompt4.png (62.7 kB)

Related questions

0 Answers