Skip to Content
author's profile photo Former Member
Former Member

Add-on restart on company change

Hi All,

Is it possible to have a Add-on for multiple companies..??? I guess it's yes that's why SAP has provided the aet_CompanyChanged event.

Now the problem I am facing is my add-on works for a company but the moment the user changes the company, the add-on is disconnected. I did write the code in the company change event to reinitialize my add-on but no luck. The worst part is the add-on works in both the company while executing through the .net solution but installing the same by .ard it doesn't work.

Any help in this case will be highly appreciated!

Thanks & Regards,

Jennifer

Add a comment
10|10000 characters needed characters exceeded

Related questions

2 Answers

  • Best Answer
    Posted on Jun 15, 2008 at 10:24 AM

    Hi Jennifer,

    for me change_company is a relict from old sap versions.

    i used this in past in 6.5 but now it isn't necessary any more - looks like it is useless now.

    the reason: since 2004 sap is disconnecting the addon and starting it again using the company addon settings.

    so what you have to do is: install the addon in both companies and set there startmode to "automatically".

    so when you change the company it's always started again.

    lg David

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Jun 17, 2008 at 05:21 AM

    While installing addon-

    In addon administration set default group as Automatic and

    Install for everyone

    regards:

    Sandy

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.