Skip to Content
0

git "invalid committer" mixup SAP accounts

Feb 06 at 02:30 PM

59

avatar image

Hello,

I have a problem committing in the SAP WebIDE to a remote git repository.

I am logged in with mail and PW of my S_User account "Sxxx3570" (mail address: ce@xyz.com). git login using the same mail address. When I commit it says "REJECTED OTHER REASON, Error message invalid committer".

After 5 login tries I get an email " 5 failed login attempts but with a SCP trial User ID Pxxx5395 (mail address: ce@xyz-consulting.com). So I guess SCP resp. git mixes up my SCP accounts. But both have different mail addresses. I tried:

- empty browser cache (as assumed in another thread)

- git login with S-user : doesn't work

- change the mail address in the git repository config (WebIDE)

I am confused how git stores the user accounts. In another thread (https://archive.sap.com/discussions/thread/3694463) there has been a hint that "You need to get rid of all commits by other users/emails". May be that is a step to the solution. But how is it done?

Kind regards

Christian

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

4 Answers

Best Answer
Michal Keidar
Feb 12 at 03:02 PM
0

Hi Tomer Epstein Michal Tall - Can you please assist?

Thanks,
Michal.

Share
10 |10000 characters needed characters left characters exceeded
Michal Keidar
Feb 07 at 07:13 AM
0

Hi Christian,

When you get this error in Web IDE, you also get a link to our troubleshooting guide, have you taken a look at it?
It says how to handle the "Invalid Committer" error:
https://help.sap.com/viewer/825270ffffe74d9f988a0f0066ad59f0/CF/en-US/bd0cb7ed7e2149b6b5170205cbde0de7.html

Regards,
Michal.

Share
10 |10000 characters needed characters left characters exceeded
Christian Engelmann Feb 09 at 10:48 AM
0

Hi Michal,

thanks for your answer! I have considered the troubleshooting and changed general and project git settings to several variations which didn't help.

Both mail addresses are valid. Let's name them ce@old.com and ce@new.com. The address has changed because my company's name has changed.

1. I can commit (remote push) a change using a local windows git client and mail address ce@old.com. So my git rep mail address is obviously ce@old.com.

At SCP and WebIDE login is only possible for me using ce@new.com or my s-user as login name:

2. When I push a change to the remote rep via WebIDE and git-login ce@old.com it says "Error: .. not authorized"

3. When I push via WebIDE using S-User or ce@new.com for git authentication it says: "REJECTED_OTHER_REASON, Error message invalid committer."

So my suggestions are:

1. Change my SAP account mail address to ce@old.com. Not nice but if it would work ok for me. I already did that but it had not an immediate effect. I could not login to SCP with that mail address. Does it take a while to have effect? Are accounts duplicated to several SAP platforms?

2. Change my account/mail address in the git repository - I have no idea where to do that in SCP.

May be this is rather a git problem but at the moment I am stuck with that.

Regards Christian

Share
10 |10000 characters needed characters left characters exceeded
Christian Engelmann Feb 12 at 04:35 PM
0

Hi Michal,

I got the problem solved. Still don't know the exact reason but that's how it worked for me:

I changed mail address of my SCP account to ce@old.com. After 1 or 2 hrs I could login with that name. So all my settings used that mail address:

- SCP account mail address

- Preferences > Git Settings > Git Email Address

- project > Git Repository Configuration > user.email

Remote push still didn't work. Then I changed my git user name. After changing remote push worked! I must have changed it during tries to fix the error.

I guess for some reasons your git settings must remain the same once you have pushed something to the repository. Within another project of my company I had used that ce@old.com git account, my SCP account had a different mail address and it worked fine.

So I am still a bit confused. May be this post will help someone else having the same problem.

Regards Christian

Share
10 |10000 characters needed characters left characters exceeded