Skip to Content
0

[Solved] Prompts fail after Cloud Agent upgrade (Max. Nr of Rows not specified)

Feb 06 at 01:54 PM

69

avatar image

Dear Developers of SAP AC. At our customer we updated the Cloud Agent to version 1.0.91 last friday, and since we have not been able to get data from SAP ERP anymore. Could it be that there is a bug in the system?

We had to go back to the old version.

The reason we upaded is that the blog you posted 2 weeks ago about the 2018.02 release it says we need to update, but did not say when the update will happen (I expected this Saturday). it would help if you state the date of the updates somewhere.

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

6 Answers

Best Answer
Daniel Spokoinyi Mar 02 at 04:29 PM
2

Turns out that the problem was that we had a Nr of Maximum rows to load enabled, causing the error. Once specified a high maximum of lines, the problem was solved.

well, Took a long while, but we got there. So, lesson learned: Be careful with Prompts, and which one's you select!

Share
10 |10000 characters needed characters left characters exceeded
Mate Kiss
Feb 06 at 02:22 PM
2

Hello Daniel,

The problem is that that the Agent (1.0.91) you have installed belongs to 2018.02.
However your SAP Analytics Cloud Tenant is not yet on that version.
In this case please do not open an incident, just wait until your System gets updated.
After that you can deploy the new Agent and the connection should work fine.

Best Regards,
Mate

Show 2 Share
10 |10000 characters needed characters left characters exceeded

ok great. But is that not a bit weird that you always have to wait for the new release to update the agent. This means, that one always has to update the agent during the weekend, to make sure that data get's loaded once the update has happened.

We will try to do it Friday and I hope it will all work Monday then.

For the SAP AC Developers: In this case it would be extremely handy to have a schedule for the updates, and the new releases of the Cloud Agent.

I was expecting the 2018.02 update last weekend, which is why we updatede the agent. We now lost quite a few hours updating, putting it back, and updating again, trouble shooting, and a really not satisfied customer who had no data updates for 2 days.

Anyway, thank you very much and I hope this will all work nog.

Daniel

1

Yes i believe the email notification for the wave update went out too early by accident, and another note was sent subsequently to signal that prematureness. regards, H

0
Julian Jimenez
Feb 06 at 03:57 PM
1

Hi Daniel,

The newer agents support "older" versions of SAP Analytics Cloud. Having the latest agent should not be a problem.

You can check the Tomcat logs to identify more clearly the error. Sometimes a simple Tomcat restart fix issues related to memory.

Thanks,

Julian

Show 1 Share
10 |10000 characters needed characters left characters exceeded

We have checked it and did not see any problems there, and we were able to fix all issues.

2
Daniel Spokoinyi Feb 06 at 02:20 PM
0

Are you using ERP as connection? Otherwise I will open an incident

Share
10 |10000 characters needed characters left characters exceeded
Tammy Powlas
Feb 06 at 01:56 PM
0

Hi Daniel - I recommend opening a SAP Support incident at support.sap.com and use component LOD-ANA-BI

I updated my cloud agent this weekend and so far I haven't experienced issues.

Share
10 |10000 characters needed characters left characters exceeded
Daniel Spokoinyi Feb 11 at 06:14 PM
0

Hey guys,

I have updated it now, and even with the new release I still have problems with updating queries. Some queries do come through, so I believe it has something to do with prompts and the new Cloud Agent.

I will put in a ticket at SAP, but if someone has any suggestion on what else to do it would be great. The Tomcat server did not show anything

Daniel

Share
10 |10000 characters needed characters left characters exceeded