Skip to Content

Java table splitter not available in PI 7.1

Feb 05 at 03:26 AM


avatar image

Dear community

I'm exporting a PI 7.1 system (ABAP&JAVA) stack and I'm faced with 2 large Java tables which I have to split. However, I can't find any option to do that using the SWPM patch 22. I use the SAP PI 7.1 DB export option and I get the ABAP splitting screens as usual but never a Java one. I set the environment variable JAVA_MIGMON_ENABLED=TRUE but that has made no difference. I tried using the splitting option first before doing the export but that doesn't help either as it again only brings up the ABAP splitter.

I also noticed that under 7.1 there doesn't seem to be a Jsplitter tool at all at least I can't find it anywhere under <SID>\SYS\global\sltools. That directory is pretty much empty and shows no signs of a jsplitter.bat file.

I downloaded CORETOOLS.SCA and deployed it but that didn't add anything much to the sltools directory and certainly didn't create the jsplitter.bat file. So that seems to be something only available to NW > 7.1?

This is a Windows/Oracle installation which I'm moving onto Linux/Oracle.

I found various topics such as this one:

But none of them seem to offer a solution that works. So I tried to see what happens when I use Netweaver 7.4 - System Copy - Export and I do indeed get a Java Split Files option screen. However, this then creates a compatibility problem with the files in the stools/sharedlib directory so the process won't continue.

Any ideas on how to successfully split Java tables in NW 7.1?

I'd appreciate any help and insight.

Thanks and regards


10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

0 Answers