Skip to Content

Running scripts with different user

Feb 05 at 08:55 AM


avatar image

Dear Community,

We are facing the following problem:

We created a script which creates directories on a fileserver and assigns the corresponding user. This should be a part of the AD Account creation process.

When an AD account is created, the path to the homedrive is generated and entered into the "Homedrive" attribute in AD. but the directory itself does not exist. So this script should create it.

The script is working fine as long as I run it with my useraccount or our service user account. But the problem is when I trigger it from IDM the script does not create the directory due to missing permissions.

We have already found out that the script is started by the local system account (nt authority\system).

Is there a way to use other credentials?

we also tried already with PSEXEC, but here we get the following error: "Access is denied"

If somebody has useful hints we would really appreciate.

Kind regards

Sergius Karsten

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Sergius Karsten Feb 05 at 03:05 PM

Found a solution by myself.

For anyone who is interessted.

You just have to start the dispatcher which is running the scripts with the corresponding user.

Then the scripts are also started with this user.

Kind regards

Sergius Karsten

Show 1 Share
10 |10000 characters needed characters left characters exceeded

Hello, Sergius, you are correct. The account running the dispatcher service must have the proper permissions.

Glad you were able to figure it out!