Skip to Content
0
Jun 10, 2008 at 04:04 PM

SM58 - Error when opening an RFC connection Loading data from BI/ECC6

1628 Views

Sometimes when I run a load from BI, i get the above error. If i go into SM58 and manually kick off the LUW it works fine. Sometimes the loads work fine and don't have any issues. It fails about about every 4th or 5th time. The system has 9 application servers and its not consistently failing on 1 application server, it will fail on any of them. I have tried re-creating the sm59 connection in both systems, the test and auth tests work fine. I have checked the /etc/services files on all the servers and they have the correct entires in them.

It happens on the 2 function modules RSAR_TRFC_DATA_RECEIVED

IDOC_INBOUND_ASYNCHRONOUS and its never consistent on which one if fails on.

Copy of the trace file.

  • Trace file opened at 20080608 212136 EDT SAP-REL 700,0,133 RFC-VER nU 3 938779

======> CPIC-CALL: 'ThSAPOCMINIT' : cmRc=20 thRc=665

Service name is not known

ABAP Programm: RSRFCPIN (Transaction: SM59)

Called function module: RFC_PING

User: VVRAO (Client: 300)

Destination: BWQCLNT400 (handle: 2, , {484898AF-5899-0107-E100-8000AC1600C9})

Error RFCIO_ERROR_SYSERROR in abrfcpic.c : 2323

CPIC-CALL: 'ThSAPOCMINIT' : cmRc=20 thRc=665

Service name is not known

HOST =172.22.0.208

SERV =sapdp10