Skip to Content
avatar image
Former Member

Assertion Failed! error when trying to install CR2016 SP5

I am currently running Crystal Reports 2016 Support Pack 4 Patch 6. (aka 14.2.4.2649)

After about 20 minutes of getting redirected in circles and dead ends, I finally managed to find a website that has updates and patches to download for CR2016 - https://websmp130.sap-ag.de/sap(bD1lbiZjPTAwMQ==)/bc/bsp/spn/patch_download/main_public.htm

I see there is a download called 'Crystal Reports 2016 SP05 Update' which (you can't determine until AFTER it's been downloaded) is 14.2.5.2618

If you just double-click on the downloaded update, it tries to unzip and then you get an error about ports not being open. (the only installer on the planet earth that does this). So I right-click and unzip the installer to a folder, then right-click on setup and run as administrator.

The installer starts, but then I get another nasty looking error - "Assertion Failed! Program: ...\src\tcp.boost\1.60.0\export\ifa.../shared_ptr.hpp Line 693. Expression: px != 0" Options are Abort, Retry, Ignore.

Tried re-downloading. Tried restarting the computer. Antivirus is disabled. Ran installer as Administrator. Tried unzipping to another folder in case it was a permissions issue. None of these steps resolved the issue.

I think SAP should:

- make finding these updates and patches a LOT easier. (I don't know, how about a 'check for updates' link in the Help menu when running CR. Or an obvious 'downloads' link on the sap website)

- test installers before releasing to the general public

- include some release notes. That would be nice. I am trying to install this update to see if it will resolve the (very) slow startup process. I have no idea if this update resolves the issue. Next to the download link (on the sap-ad.de link I mentioned above) there is a tiny blue dot. if you click on it, a pop-up appears that is probably supposed to have some human-readable information. But instead it's a mashup of random code and words. Also, after unzipping the installer, there are no release notes in here either. So again, no clue what this update even does other than it's called a 'service pack' on this web page, but in CR's about screen it's called a 'support pack'.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Feb 05 at 05:11 PM

    Eric,

    I do not believe update to SP05 will address the slow Start-Up issue. You probably saw my reply on the relevant post.

    The error "Assertion Failed!" usually caused by version mismatch between different BI components like Crystal reports and BI Server or BI Client Tools on the same machine. To work properly all BI products on the machine should be on the same patch level.

    My suggestion is to undo the CR update until we get CR slow start-up resolved.

    Add comment
    10|10000 characters needed characters exceeded