Skip to Content
avatar image
Former Member

Webservice to file (receiver determination problem)

Hi ...

I am doing webserive to file scenario in PI7.0 server. I have completed doing the scenario. But there is a problem in receiver side. In SXMB_MONI it is showing the below error.

<?xml version="1.0" encoding="UTF-8" standalone="yes" ?>

- <!-- Receiver Identification

-->

- http://sap.com/xi/XI/Message/30" xmlns:SOAP=" http://schemas.xmlsoap.org/soap/envelope/" SOAP:mustUnderstand="1">

<SAP:Category>XIServer</SAP:Category>

<SAP:Code area="RCVR_DETERMINATION">NO_RECEIVER_CASE_BE</SAP:Code>

<SAP:P1 />

<SAP:P2 />

<SAP:P3 />

<SAP:P4 />

<SAP:AdditionalText />

<SAP:ApplicationFaultMessage namespace="" />

<SAP:Stack>No receiver could be determined</SAP:Stack>

<SAP:Retry>N</SAP:Retry>

</SAP:Error>

Could you please help me out in this.

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

4 Answers

  • avatar image
    Former Member
    Jun 10, 2008 at 10:58 AM

    hi

    did u maintain the receiver service in the receiver determination

    check it f 7

    regards

    chandra

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jun 10, 2008 at 10:58 AM

    Hi,

    go to SXMB_MONI->Trace from leftside menu and check all your business services , reciever interfaces etc configured in the directory are same as in the runtime.

    Also check the configuration, and activate it again. Hope this reciever business service is pointing to correct R/3 system..

    Refresh the cache in the directoy, SXI_CACHE and go to integrtaion builder(XI homepage)->Administration->Cache Overview->Refresh all the caches for Repository,Directory and Runtime.

    Changing the receiver determination and activating again will help you

    Hope this helps

    Also go through the below link

    errorrcvrdeterminationnoreceivercasebe

    Please reward points if it helps

    Thanks

    Vikranth

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jun 10, 2008 at 11:00 AM

    Have you configured your legacy system as Business Service? Have you attached you MI and Interface mapping in the Interface determination and configured your communication channel properly in receiver agreement?

    regards

    chandra

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jun 10, 2008 at 11:03 AM

    If you are using SOAP Adapter, The URL should be as follows:

    http://<XI-host>:<J2EE_Port>/XISOAPAdapter?MessageServlet?channel=party:service:channel

    Under party:service:channel enter the party name, the service name, and the name of the communication channel.

    If no party has been created, enter the following: channel=:service:channel.

    regards

    chandra

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      hi,

      When you have used the WSDL wizard in the Integration Directory and have clicked on "Propose URL" in the second screen, did you ever wonder, why the URL does not point to a sender SOAP adapter channel, it is the URL of the Integration Server instead?

      When you want to use the inbound channel of the Integration Server, you have to use following URL for the web service client:

      http://<server>:<ABAP-port>/sap/xi/engine?type=entry&version=3.0&Sender.Service=<YourService>&Interface=<YourNamespace>%5E<YourInterface>

      The namespace must be written with escaped characters. (%5E stands for "^")

      Note: The WSDL wizard creates an address with the escape sequence &amp; instead of &. Some SOAP clients (for example XPLSpy) do not automatically restore the character and you have to do this manually.

      By default the SOAP call is treated as a synchronous call. If you want an asynchronous call, you have to add &QualityOfService=ExactlyOnce to the URL.

      Additionally your web service client must provide the HTTP header parameter "SOAP action" = http://sap.com/xi/WebService/soap1.1

      The Web Service Wizard of the Integration Repository creates a WSDL concerning this URL and this SOAP action automatically. Only for asynchronous calls you need to change the URL inside the WSDL file with an editor and add &QualityOfService=ExactlyOnce.

      Advantage

      When you send SOAP messages directly to the Integration Server, you reduce the message load on the adapter engine. This can improve the performance.

      Restrictions

      The SOAP inbound channel of the Integration Server does not support attachments. SOAP messages with content type "multipart" are rejected.

      Hint

      For testing purpose it is possible to add logon data directly to the URL. The parameters are the same as in the HTTP sender adapter: &sap-user=<username>&sap-password=<password>

      /people/stefan.grube/blog/2006/09/21/using-the-soap-inbound-channel-of-the-integration-engine

      regards

      chandra