Skip to Content

Problem with SOAP receiver adapter? Please help!

Hi experts

I have the following scenario:

SAP R/3 -ABAP Proxy >XI--->SOAP --webservice

As you can see, I am sending data from R/3 system to XI via ABAP proxy. XI then sends data or calls a webservice via SOAP adapter.

When I test this scenario I am getting a error in the sxmb_moni that is,

"com.sap.aii.af.ra.ms.api.DeliveryException: TEXT/HTML; HTTP 504 Gateway Time-out"

I have checked the webservice url and it is working fine.

Can somebody tell me why am I getting this error message? How do I resolve this?

Thanks

Gopal

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

3 Answers

  • avatar image
    Former Member
    Jun 10, 2008 at 09:23 AM

    Check the proxies setting in the SOAP receiver communication channel.

    Also check the status of the SOAP receiver CC in the CC Monitoring for more details.

    Thanks

    Farooq.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jun 10, 2008 at 09:27 AM

    Hi gopalkrishna,

    The 504 Gateway Timeout error is an HTTP status code that means that one server did not receive a timely response from another server that it was accessing while attempting to load the web page or fill another request by the browser. This usually means that the other server is down or not working properly.

    Go to SXMB_ADM in runtime parameter increase the value of HttpTimeOut to 6000 from 3000

    Reward Points if Helpful

    Thanks

    Sunil Singh

    Add comment
    10|10000 characters needed characters exceeded

  • Jun 10, 2008 at 09:30 AM

    Hi,

    Can you please check the settings in Soap Adapter with Module Adapter setting with ModuleTranformBean parameters? There may be some problem. use HTTP Adapter and the message type 'HttpPostIn' to send as HTTP Post.

    Also

    There is the note 450226 gives an overview over error codes

    Probably below solution may help you.........

    As an administrator on your portal go to:

    System Configuration > Service Configuration >applications

    Under: com.sap.portal.ivs.httpservice > Services > Proxy

    If any proxy settings are configured you may end up with the problem, so you need to set the "nonProxyHosts" to include the trex host.

    regards

    Aashish Sinha

    PS : reward points if helpful

    Add comment
    10|10000 characters needed characters exceeded