Skip to Content
0

Problem with showing IoT data into Fiori App

Feb 01 at 03:28 PM

73

avatar image

By creating a Fiori Application with the IoT Template, I was able to show the IoT device it's data. With full setup of the IoT Device in the IoT Service Cockpit and with the related Thing Type and Things. In the beginning everything worked properly but after time i got the following error:

The following problem occurred: HTTP request failed500,Internal Server Error,{"error":{"code":null,"message":{"lang":"nl-nl","value":"Common Server Error. Check log for more details"}}} -

I can reload the page and sometimes the data is perfectly loaded into the Fiori App. But most of the time it's not showing anything at all. Sometimes it's shows only half of the data.

Already tried:

- creating new Thing Type with Things

- reconfigure the destinations

- Create a new Fiori IoT Template

(Data is shown in template wizard)

Still the same error. Very random and rarely the data is shown.

Someone has an idea?


Thanks in advance

Dries Van Vaerenbergh

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

Best Answer
Marcus Behrens
Feb 02 at 12:04 PM
0

This is a known issue with the advanced thing list api, which is the basis of the thing list ui control. We are tracking this closely and are looking to provide a resolution ASAP. Other then tickets you might have created if you are a customer then your administrator should have access to https://jam4.sapjam.com/groups/kcKhhbRCPL3PQft2XM1d6X/overview_page/QMCk9FNB1Ck9ymiqJjdtiN where we provide updates on issues that affect all customers. The hotfix deployed today might not yet be the final resolution but we are working on it.

Show 2 Share
10 |10000 characters needed characters left characters exceeded

Fix is underway - ETA (Estimated Time of Arrival) is beginning of next week - I will provide an update in this thread when this is in and you can continue developing.

0

Thank you for the information and keeping us up-to-date!

0
Marcus Behrens
Feb 05 at 04:35 PM
1

Problem has been fixed 2 hours ago - please try again!

Show 1 Share
10 |10000 characters needed characters left characters exceeded

It works again thank you!

0