Skip to Content
avatar image
Former Member

Unable to see the root node in the import manager

Hi All,

I want to load an xml file based on the schema .

I am unable to see the node <Record> containing the records in the import manager.

What I am seeing now in import manager Source Hierarchy is

> None

>ns1:MT_MDM_003_Shipping

What I am supposed to see

> None

>ns1:MT_MDM_003_Shipping

>Record

Could anyone let me know if the structure of xml or schema is wrong below.

XML File:

<?xml version="1.0" encoding="utf-8"?>

http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="urn:Test-com:Customer_Master J:\Data\MDM\CUSTOM 1\IMPORT2\MT_MDM_003_Shipping.xsd">

<Record>

<Sales_Organization>1001</Sales_Organization>

<Distribution_Channel>00</Distribution_Channel>

<Division>00</Division>

<Customer_Nr>00114</Customer_Nr>

<Order_Combination>Y</Order_Combination>

<Complete_delivery_reqd_by_law/>

<Max_partial_deliveries/>

<Delivery_Priority/>

<Shipping_Conditions/>

<Delivering_Plant/>

<Partial_delivery_per_item/>

</Record>

</ns1:MT_MDM_003_Shipping>

XSD File:

<?xml version="1.0" encoding="UTF-8" ?>

http://www.w3.org/2001/XMLSchema">

<xsd:element name="MT_MDM_003_Shipping" type="DT_MDM_003_Shipping" />

<xsd:complexType name="DT_MDM_003_Shipping">

<xsd:annotation>

3c427550330e11dda6b400112539c3abhttp://sap.com/xi/TextID">3c427550330e11dda6b400112539c3ab>

</xsd:annotation>

<xsd:sequence>

http://www.w3.org/2001/XMLSchema">

<xsd:annotation>

414ccfd01c4f11dd8b8b02004c4f4f50http://sap.com/xi/TextID">414ccfd01c4f11dd8b8b02004c4f4f50>

</xsd:annotation>

<xsd:complexType>

<xsd:sequence>

http://www.w3.org/2001/XMLSchema">

<xsd:annotation>

414ccfd11c4f11ddb25802004c4f4f50http://sap.com/xi/TextID">414ccfd11c4f11ddb25802004c4f4f50>

</xsd:annotation>

</xsd:element>

http://www.w3.org/2001/XMLSchema">

<xsd:annotation>

414ccfd21c4f11dd800802004c4f4f50http://sap.com/xi/TextID">414ccfd21c4f11dd800802004c4f4f50>

</xsd:annotation>

</xsd:element>

http://www.w3.org/2001/XMLSchema">

<xsd:annotation>

414ccfd31c4f11dd99b802004c4f4f50http://sap.com/xi/TextID">414ccfd31c4f11dd99b802004c4f4f50>

</xsd:annotation>

</xsd:element>

<xsd:element name="Customer_Nr" type="xsd:string">

<xsd:annotation>

414ccfd41c4f11ddb93902004c4f4f50http://sap.com/xi/TextID">414ccfd41c4f11ddb93902004c4f4f50>

</xsd:annotation>

</xsd:element>

http://www.w3.org/2001/XMLSchema">

<xsd:annotation>

414ccfd51c4f11dd871702004c4f4f50http://sap.com/xi/TextID">414ccfd51c4f11dd871702004c4f4f50>

</xsd:annotation>

</xsd:element>

http://www.w3.org/2001/XMLSchema">

<xsd:annotation>

414ccfd61c4f11dda64f02004c4f4f50http://sap.com/xi/TextID">414ccfd61c4f11dda64f02004c4f4f50>

</xsd:annotation>

</xsd:element>

http://www.w3.org/2001/XMLSchema">

<xsd:annotation>

414ccfd71c4f11dd832102004c4f4f50http://sap.com/xi/TextID">414ccfd71c4f11dd832102004c4f4f50>

</xsd:annotation>

</xsd:element>

http://www.w3.org/2001/XMLSchema">

<xsd:annotation>

414ccfd81c4f11dda0e902004c4f4f50http://sap.com/xi/TextID">414ccfd81c4f11dda0e902004c4f4f50>

</xsd:annotation>

</xsd:element>

http://www.w3.org/2001/XMLSchema">

<xsd:annotation>

414ccfd91c4f11ddb21602004c4f4f50http://sap.com/xi/TextID">414ccfd91c4f11ddb21602004c4f4f50>

</xsd:annotation>

</xsd:element>

http://www.w3.org/2001/XMLSchema">

<xsd:annotation>

414ccfda1c4f11dd9e5402004c4f4f50http://sap.com/xi/TextID">414ccfda1c4f11dd9e5402004c4f4f50>

</xsd:annotation>

</xsd:element>

http://www.w3.org/2001/XMLSchema">

<xsd:annotation>

414ccfdb1c4f11ddaf1202004c4f4f50http://sap.com/xi/TextID">414ccfdb1c4f11ddaf1202004c4f4f50>

</xsd:annotation>

</xsd:element>

</xsd:sequence>

</xsd:complexType>

</xsd:element>

</xsd:sequence>

</xsd:complexType>

</xsd:schema>

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

4 Answers

  • Best Answer
    Jun 10, 2008 at 07:02 AM

    Hi Aravind,

    I tried creating an XSD without the Namespace definition "targetNamespace="urn:Test-com:Customer_Master" and thus an XML without the NS1 in the root tag. Doing so, the import works as expected. This looks like an issue of the Import Manager... Can you get rid of the namespace definitions in your scenario?

    Best regards

    Michael

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jun 10, 2008 at 04:13 AM

    Hi Aravind,

    Try importing two records i.e. your XML file should consists of two record nodes

    <?xml version="1.0" encoding="utf-8"?>

    http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="urn:Test-com:Customer_Master J:\Data\MDM\CUSTOM 1\IMPORT2\MT_MDM_003_Shipping.xsd">

    <Record>

    <Sales_Organization>1001</Sales_Organization>

    <Distribution_Channel>00</Distribution_Channel>

    <Division>00</Division>

    <Customer_Nr>00114</Customer_Nr>

    <Order_Combination>Y</Order_Combination>

    <Complete_delivery_reqd_by_law/>

    <Max_partial_deliveries/>

    <Delivery_Priority/>

    <Shipping_Conditions/>

    <Delivering_Plant/>

    <Partial_delivery_per_item/>

    </Record>

    <Record>

    <Sales_Organization>1001</Sales_Organization>

    <Distribution_Channel>00</Distribution_Channel>

    <Division>00</Division>

    <Customer_Nr>00114</Customer_Nr>

    <Order_Combination>Y</Order_Combination>

    <Complete_delivery_reqd_by_law/>

    <Max_partial_deliveries/>

    <Delivery_Priority/>

    <Shipping_Conditions/>

    <Delivering_Plant/>

    <Partial_delivery_per_item/>

    </Record>

    </ns1:MT_MDM_003_Shipping>

    Please change the data of second record accordingly. I also faced the same problem and some how manage to get this solution. Lets see whether it is working in your case.

    Regards,

    Jitesh Talreja

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi,

      I tried importing your XML file but it doesnt validate with the XSD.

      I observed that when there is only one record present in the XML then it is not showing the Record node but all the entries or elements present in the record node are available in the Root node visible in the Import Manager.

      When we are creating two records in the XML then Record node is visible and it is joined with the Root node and we can lookup to all the elements present in the Record node and can do the mapping.

      Now just try this

      1. First try to validate your XML with XSD

      2. Save the Import Manager map for the file with two records i.e. same first lookup all the record elements and map one to one with the repository fields accordingly

      3. With this map try to import XML with one record present in it and check whether it is successful or not. If it is successfully imported then your issue will be solved.

      Regards,

      Jitesh Talreja

  • avatar image
    Former Member
    Jun 09, 2008 at 08:58 PM

    Any Help regarding the issue.Does the import manager only allow one xml file per import.I guess the schema definition is not correct...

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      I guess the schema is not valid.any Help on the given schema definition and why the import manager is not showing the Records tag in the Source dropdown of the import manager??

      Any Help greatly appreciated...

      Thanks

  • avatar image
    Former Member
    Jun 25, 2008 at 04:36 PM

    Problem solved:

    Namespace in XML

    -


    Hello

    We are facing the same problem. We have taken the XSD form PI which has the name space. Either the import manager nor the syndicator can find the root node correctly.

    We are unable to turn off the name space in the XML from XI - how did you solve that?

    BR

    /Alexander

    Edited by: Alexander Isacson on Jun 25, 2008 6:59 PM

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi,

      Remove the namespace from xsd using some editor.If there is any namespace reference in xml too remove it.

      Give the sample and I might help you...