Skip to Content
0

Deploying apps from a higher version(SAPUI5 - WEBIDE) to a system with a lower one (ABAP System)

Jan 31 at 10:55 PM

239

avatar image
Former Member

Hi experts, I'm currently in working on a Fiori project, all the applications are going to be "Z" and all the applications need to be deploy to the ABAP system. The ABAP system currently has installed SAPUI5 version 1.28.44, the thing is that i'm going to devolp my apps (SAP WEB IDE) on a higher version than the current one (ABAP system).

Is there a way to deploy my application to the ABAP System to a higher version without any problems?

Thanks in advance.

Regards

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

5 Answers

Best Answer
Sharath M G Feb 01 at 08:27 AM
0

You will have no issue in deployment. But, in the UI5 code behavior is depended on version match between ide and runtime of ABAP server.

Best Scenario: You should be easily upgrade the UI5 version on server.

Workaround: If that is not at all possible, then ensure that the controls or apis used in Web IDE are still available in the lower UI5 version in ABAP runtime.

Regards,

Sharath

Show 1 Share
10 |10000 characters needed characters left characters exceeded
Former Member

Thank you Sharath, We have decided to upgrade the fiori server to FES 4.0 (SAPUI5 1.50)

Thanks, Greetings

0
Hamdan Khalid Feb 01 at 05:59 AM
0

Dear Juan,

I faced the similar situation, on my client they max UI5 version as 1.28 installed on there system,
I developed my apps using 1.38, when I deployed my app, even simple controls that were available since 1.22 (like combo box) was not working.
So its strongly recommended to develop your app on a compatible version.

Thanks,
Hamdan.

Show 3 Share
10 |10000 characters needed characters left characters exceeded

are you sure?

0

I shared my experience, I was beginner at that time, so may be I might have done something wrong.

Thanks.

0
Hamdan Khalid

so better not sharing those thing...

0
Jun Wu Feb 01 at 03:54 AM
0

as long as you are not using feature from higher version, you should be fine.

Show 1 Share
10 |10000 characters needed characters left characters exceeded
Former Member

Thank you Jun Wu, We have decided to upgrade the fiori server to FES 4.0 (SAPUI5 1.50)

Thanks, Greetings

0
Elina Visoki
Feb 01 at 04:04 PM
0

Hi Juan,

you can simply change the version your application is using in the Web IDE.

right click on the project -> project settings -> SAPUI5, choose the UI5 version available in your ABAP server and save.

after the update, the code completion, validations and the preview of the app will be according to this version.

you can also update only the preview version in the run configurations -> advanced settings.

Best regards,

Elina

Show 1 Share
10 |10000 characters needed characters left characters exceeded
Former Member

Thank you Elina, We have decided to upgrade the fiori server to FES 4.0.

Thanks, Greetings

0
Neil Ward Feb 06 at 11:17 AM
0

Another option is to use a CDN to get the UI5 library rather than the fiori front end server.

https://help.sap.com/doc/a7b390faab1140c087b8926571e942b7/7.51.4/en-US/843dafd6bf0c413e9a5fe698e1550380.html

Show 1 Share
10 |10000 characters needed characters left characters exceeded
Former Member
Thank you Neil, interesting your answer. We will keep it in mind for the future. We have decided to upgrade the fiori server to FES 4.0.

Thanks, Greetings

0