Skip to Content
0
Former Member
Apr 02, 2008 at 01:19 AM

Xcelsius 4.5 fully compatible with Vista???

19 Views

I have Xcelsuis 4.5 Standard that I'm running on Vista.

I originally ran Xcelsius on XP and it worked perfectly.

Now, with Vista, it's really glitchy! Are there any patches

or Xcelsius service packs to make 4.5 more stable on Vista?

I WAS planning to upgrade to Xcelsius 4.5 Professional but

I assume that there would still be issues running on Vista.

Is Xcelsius 2008 FULLY compatilble with Vista????

Would I get considerably BETTER results by upgrading to Xcelsius 2008?

Also, is Xcelsius 2008 an improvement over 4.5 Professional???

Thank you!

Roger