Skip to Content
0

Process Integration Scenario - "No imported software component version exists for product" error

Oct 25, 2016 at 11:44 AM

141

avatar image
Former Member

Hello!

I know there were similar posts but no answer was given.

When I try to insert an action into process integration scenario object, an error appears, like on screenshot.

In fact there was a bit of my fault. This SC existed (including ESR part) but I deleted it from SLD by accident. Then I created it again. I also deleted it from ESR and reimported.

After that there is no possibility to insert actions for this SC into a scenario definition.

It is not critical for work but I would like to fix it if possible. Is there any solution?

Best regards,

Andrey

action.png (39.5 kB)
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

4 Answers

Best Answer
Mark Smyth
Nov 02, 2016 at 11:22 PM
0

Hi Andrey,

Try the solution documented in the SAP KBA 1695493 Newly added SWCV in SLD Product missing in PI ESR.

Regards
Mark

Show 1 Share
10 |10000 characters needed characters left characters exceeded
Former Member

Mark,

wow! It now works!

Closing the question.Big thanks to you.

0
avatar image
Former Member Oct 25, 2016 at 12:47 PM
1

Hi Andrey,

When you delete and create in SLD then new GUID will be created in SLD, so you need to re import the new software component into repository.

In the process integration scenario you need to remove the old product and re assign the new product from the SLD.

Make sure you have the same GUID in repository and SLD for software component.

Clear the SLD cache in repository and directory and try.

Regards,

Praveen.


repositoryguid.png (11.5 kB)
sldguid.png (59.6 kB)
Show 3 Share
10 |10000 characters needed characters left characters exceeded
Former Member

Hello Praveen.

I reimported it even several times during latest days (after each deletion and recreation).

GUIDs are equal (I've checked).

All of this didn't help.

I think something become corrupted after my initial actions but I don't know how to fix it.

0
Former Member
Former Member

Hi Andrey,

Did you remove the existing product from process integration scenario and re assign the new product from SLD again? Did you clear the SLD cache?

Regards,

Praveen.

0
Former Member
Former Member

Praveen,

yes, I did all mentioned steps.

Hoped it would be like building from scratch. But no, something prevents me from working with SC with this name.

0
Iñaki Vila Oct 25, 2016 at 11:50 AM
0

Hi Andrey,

Have you tried with the Release Transfer option?:

https://help.sap.com/saphelp_nw74/helpdata/en/e8/e8573ba5f13048be50532fc3fcea9c/frameset.htm

Regards,

Show 1 Share
10 |10000 characters needed characters left characters exceeded
Former Member

Hi Iñaki.

No, I haven't. What would the best strategy be?

To transfer my component to another SC?

It would be better if an SC remained with its present name.

0
G Lakshmipathi
Oct 25, 2016 at 12:32 PM
0

Have a look at OSS note 1989223

Show 1 Share
10 |10000 characters needed characters left characters exceeded
Former Member

Hi.

As far as I understand, this note is about "using one of the SAP delivered Enterprise Services Repository (ESR) contents e.g. SAP SNC". And I have a software component created by me, not by SAP.

0