Skip to Content
author's profile photo
Former Member

Previewing a report in Eclipse

I have installed Eclipse 3.2 and CrystalReports for Eclipse.

After some (ok, a lot of) time, I managed to create a connection to my Oracle DB.

(I got confused by the fact that no driver was selectable in the combobox...)

I then created a trivial report (I have read the available white paper and modified the example to suit my database).

My problem:

When I click the preview tab, I see: nothing. To be more specific, I see a gray surface with absolutely nothing on it.

I tried creating a new report, with just some static text and a line on it: when I (try to) preview that, I see the same empty gray surface.

Assuming that previewing inside Eclipse should work (or produce an error message): any idea what might be or what I might be doing wrong?

Kind regards and thank you,

Christoph

PS: I have not yet tried programming (in Java?) to produce a report. What other possibilities are there (besides the not (yet) working preview from within Eclipse to 'view' a report.

PPS: I am running linux.

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

1 Answer

  • author's profile photo
    Former Member
    Posted on Aug 22, 2007 at 08:34 PM

    Reading the other thread 'All in one version locks up eclipse when preview is selected' I have found out that my issue, too, is due to a bad Java version.

    Using JDK1.4.2 Eclipse was very unhappy and produced a NullPointerException after starting up and suggested that I should quit Eclipse...

    Using JDK1.6.0 Eclipse and the Crystal designer both worked but I got not preview (without further comments).

    Finally, using

    "BEA Systems, Inc.

    java.version = 1.5.0_04"

    (a JRE I had lying on my disk after installing some Intel VTune eval some time ago) the preview does work now.

    Obviously, it would be great if it would work with the most recent Javas as well.

    Regards

    Christoph

    Add comment
    10|10000 characters needed characters exceeded