Skip to Content

Text Fields in SRM is not editable

Hi,

We are implementing SRM 5.0 --> Stratagic Sourcing

When we create a new Bid Invitation---- -> Header Data > Documents view.---

We are facing the following issue in the Bidding Process.

When we are in the Change mode in the Document Tab, we are unable to write text in Std. Text fields, i.e. Header Text etc.

In other words the fields are greyed out.

Kindly look into same and provide a solution.

For Helping points will be awarded.

Regards

MM Team

Add a comment
10|10000 characters needed characters exceeded

Related questions

5 Answers

  • author's profile photo Former Member
    Former Member
    Posted on Jun 06, 2008 at 10:46 AM

    Hello,

    Have you implemented BBP_LONGTEXT_BADI? We can make some text types non-editable using this BADI.

    Rgds,

    Prasanna

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jun 06, 2008 at 11:29 AM

    Hi ,

    I have a suggestion for you though it looks odd as it worked in our case.

    Once the bid is published then if we go to change then as you said the text is getting greyed out as you mentioned.

    But if the bid is published then go to change and click on Hold. Then your bid invitation will become held. Go back and click on your held bidinvitation and try to click change, go to the Header --> Documents --> Texts, it will open and you can enter in the standard texts, once this is published then the text is saved.

    I think since a bid invitation is published the bidder can act on the sametime when you change text so you have to make it hold before changing anything in that.

    Try this out as it worked for us, I dont know if this will work for you as well.

    Best regards,

    Sridhar.

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jun 11, 2008 at 08:51 PM

    Hi,

    Check note 987686, 987640 as the correction of the note is responsible for the behaviour of the text control. Do a manual check if the corrections exists.

    987640 Text Editor missing under documents tab for all BO

    987686 BBPSC01: Notes for Approval Text Area not displayed

    In addition, kindly apply the following notes

    1107501 Navigation Disabled when Pasting Characters from MS-word

    1022687 BBP_UI_CONTROL_BADI fields not rendered as configured

    If the notes are in place and the issue persists, the next reason is due to the java plug-in having some issues. The applet initialisation might be failing. This might be because of the CFilesApp.jar file is not loading correctly.

    Delete/Make a backup of your existing file and kindly download the latest JAR file from the note 1034072 and test the issue.

    This should resolve the issue.

    thanks,

    Ashwin

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jun 11, 2008 at 11:09 PM

    Hi,

    Which SP level are you on for SRM 5.0??If you are on SP 9 or lower then you need to apply few notes.

    See this thread :

    text-fields-in-srm-is-not-editable

    BR,

    Disha.

    Do reward points for useful answers.

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jun 16, 2008 at 06:37 PM

    Hi,

    If you have cross-checked my recommendationon Jun 11, 2008 10:51 PM , it should resolve the issue for you.

    thanks,

    Ashwin

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.